summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-20 16:58:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-20 17:33:44 +0100
commitce5561954df9a6db238dd000501cadf5c14cffa8 (patch)
treecada56f78dcb001993fbaf4be6c3ef0f29b73aa8 /dev-python
parentdev-python/markupsafe: Remove old (diff)
downloadgentoo-ce5561954df9a6db238dd000501cadf5c14cffa8.tar.gz
gentoo-ce5561954df9a6db238dd000501cadf5c14cffa8.tar.bz2
gentoo-ce5561954df9a6db238dd000501cadf5c14cffa8.zip
dev-python/yarl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/yarl/Manifest3
-rw-r--r--dev-python/yarl/yarl-1.14.0.ebuild60
-rw-r--r--dev-python/yarl/yarl-1.15.5.ebuild66
-rw-r--r--dev-python/yarl/yarl-1.16.0.ebuild66
4 files changed, 0 insertions, 195 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index fd45812c5173..a52ce8e7d99c 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,5 +1,2 @@
-DIST yarl-1.14.0.tar.gz 166127 BLAKE2B 7974896144ef23309aead8935f18fe717e39b982bc75eb3c828eaf9a1d01b413c2bbb270344160a396927fc32571928c67eae46146920cc6908e2e3f74e90cd8 SHA512 8cc9d1aaa6fcccdfce5ea0a0ac3f89b81c5719568b76e66637e9a7baa0637770523f86495f70e28f94f166579e77d72afd708cef1306dafcd8093c7fb2a1d3f0
-DIST yarl-1.15.5.tar.gz 172410 BLAKE2B 49d31ed31466921a04d1e83d98c6ec742aaa71a7675da9c9ee4f99ce4ca6813cd471e92e8ee78e4c33c3ea2efe981b8603bf677100b1e9b8f6de3324e2c43074 SHA512 d1219971f5bc90e1d1f4b256a8e90fd98433086cb326f658bd68bfaefd97c12c0ff8121ab16fdd047236f29ce6c3907ea6b0afbde3526fe8ec290dec379ca732
-DIST yarl-1.16.0.tar.gz 176548 BLAKE2B 038934a1ef05c78fd04702ed4519c121b7e9c5e6f41069e179cd7f09c178da9e6a73ab14cf5083dfa0597b24ed351dac0d937f419c58e510c9eb695c3639d2f3 SHA512 ee3933aed6ac0cc5df24cd0e8f3d3d560348b4a7c960562a7bee16e105b6104e24c5720388cd4a1ae20f796f27bf0ce8c599999d554e3cd790c6db27c6799d22
DIST yarl-1.17.1.tar.gz 178163 BLAKE2B 88d864944829e4b69ae346b0c6eb205969e9f9d2326d46f1eb4ed0506516f71730731763daf56e8230b699d5775c053c4750f6a770422cad392199ba5c099074 SHA512 5c1c25a8b828694a6538e7a07d01fc5d14238b279f8db4d76ee247a4f043b3e836c292cf6a77bb5ba544ec43dee449f2417eb0a5aaed6954449043a0fea3f811
DIST yarl-1.17.2.tar.gz 178947 BLAKE2B 5cca5ef7fa2745f76c72ba0fbd54a62344f8961d365f6777812cec6c44d42d3a573f25db25b3afe7ff93775aaff8c4f71a6cf13ed86061e14e37cab984c0d7d8 SHA512 d99cfb5bb89f60b41cad021af5971e42439f47c77b24de0ab43c372cedb15ee18bfca478889f002a322e24838e2978c30923f965ea879ba52549644b2a957348
diff --git a/dev-python/yarl/yarl-1.14.0.ebuild b/dev-python/yarl/yarl-1.14.0.ebuild
deleted file mode 100644
index 364010bcf888..000000000000
--- a/dev-python/yarl/yarl-1.14.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Yet another URL library"
-HOMEPAGE="
- https://github.com/aio-libs/yarl/
- https://pypi.org/project/yarl/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-RDEPEND="
- >=dev-python/idna-2.0[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
- >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- native-extensions? (
- dev-python/cython[${PYTHON_USEDEP}]
- )
- dev-python/expandvars[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- local -x YARL_NO_EXTENSIONS=0
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local opts=()
- # note different boolean logic than for backend (sigh)
- local -x YARL_NO_EXTENSIONS=
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
-
- rm -rf yarl || die
- epytest -o addopts= "${opts[@]}"
-}
diff --git a/dev-python/yarl/yarl-1.15.5.ebuild b/dev-python/yarl/yarl-1.15.5.ebuild
deleted file mode 100644
index 0ac6ae66078b..000000000000
--- a/dev-python/yarl/yarl-1.15.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Yet another URL library"
-HOMEPAGE="
- https://github.com/aio-libs/yarl/
- https://pypi.org/project/yarl/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-RDEPEND="
- >=dev-python/idna-2.0[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
- >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- native-extensions? (
- dev-python/cython[${PYTHON_USEDEP}]
- )
- dev-python/expandvars[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- local -x YARL_NO_EXTENSIONS=0
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # benchmarks
- tests/test_quoting_benchmarks.py
- tests/test_url_benchmarks.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local opts=()
- # note different boolean logic than for backend (sigh)
- local -x YARL_NO_EXTENSIONS=
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
-
- rm -rf yarl || die
- epytest -o addopts= "${opts[@]}"
-}
diff --git a/dev-python/yarl/yarl-1.16.0.ebuild b/dev-python/yarl/yarl-1.16.0.ebuild
deleted file mode 100644
index 0ac6ae66078b..000000000000
--- a/dev-python/yarl/yarl-1.16.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Yet another URL library"
-HOMEPAGE="
- https://github.com/aio-libs/yarl/
- https://pypi.org/project/yarl/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-RDEPEND="
- >=dev-python/idna-2.0[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
- >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- native-extensions? (
- dev-python/cython[${PYTHON_USEDEP}]
- )
- dev-python/expandvars[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- local -x YARL_NO_EXTENSIONS=0
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # benchmarks
- tests/test_quoting_benchmarks.py
- tests/test_url_benchmarks.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local opts=()
- # note different boolean logic than for backend (sigh)
- local -x YARL_NO_EXTENSIONS=
- if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
- YARL_NO_EXTENSIONS=1
- fi
-
- rm -rf yarl || die
- epytest -o addopts= "${opts[@]}"
-}