summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-07 06:28:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-07 06:28:56 +0100
commitb16555260d21f6918b89593f93ec17f3b6703151 (patch)
tree9c36667f0df361a6a022a42a563d9ae41a8d30dc /dev-python
parentprofiles/features/time64: Mask old GCC versions (diff)
downloadgentoo-b16555260d21f6918b89593f93ec17f3b6703151.tar.gz
gentoo-b16555260d21f6918b89593f93ec17f3b6703151.tar.bz2
gentoo-b16555260d21f6918b89593f93ec17f3b6703151.zip
dev-python/botocore: Bump to 1.35.55
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.55.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 81f0badf69b1..68c8ae99e773 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.35.44.gh.tar.gz 13472693 BLAKE2B a38fd45888ee1e77d7dec3fbd5aeb9f94cd825d1d54bd11a467ef9938753724958fc28eae4316d1802c729f02874113b028a929afb3de64400723c144d5d0eef SHA512 52f6c507efe175deef4e824c038f2db620f35f53f62a1372815b9c75a3638e371d89a8aa19f481f4ee29e58e5c30e5f9083fe14eb08048f80cd0f9aa1730841c
DIST botocore-1.35.49.gh.tar.gz 13473579 BLAKE2B 0b1a0e8ec76ad0d4ec677532626c4f34383828415ae6a6dc318a8e7864f2756c5618e0086a02f29726844e585895492b0e80d5e944e67fa5c233122a35a75eab SHA512 abcbcd3e8c5c4704755f83290aa8c65ee703c5f75cecab45d58451e2960f341e73042b61c28fd42a671562b25795255392d13db60c6c9d2f944f04ede6d3e78d
DIST botocore-1.35.54.gh.tar.gz 13569174 BLAKE2B 1f4cb326d27ef028e16b20838fe1f7bc32cc5c782694d4d47dc2d0cd1384a7fdfe584f6225f41004c8e4c9028c1ac2b2b157daa073adab515d99a2cf1d42b19f SHA512 cab2956d9b7597295d761f232b9981085bb4daec182514fb514b6aed7bdb82ddca41b7b85900987f624828ae389f4ac282b0950692d965ccb9b67d6ce3d40362
+DIST botocore-1.35.55.gh.tar.gz 13573450 BLAKE2B e1066fd6739932086d39ab889f020f50b32d06dd634fce7f3d357a5cbfdbba441f7a2a6863239a73fbd5a9e2e376b6a96af82ac9cbbf9ebfb8b894c85288ad8a SHA512 5744bc972ce3d6be738d2e5dff524607606759803124f335fc3b55c20158c2a34c3fbfc39fe47b8b539ace2c0e352bc8f1abc121c6d9c1ac7977f9a5de5a4b6b
diff --git a/dev-python/botocore/botocore-1.35.55.ebuild b/dev-python/botocore/botocore-1.35.55.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.55.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}