summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-27 05:27:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-27 06:47:04 +0100
commit9fba03a74b778758b754512eda6f2ed00a9cd84b (patch)
treeabe4ceebd46cc6e07e0024e47ee287132dfc75d5 /dev-python
parentapp-admin/awscli: Bump to 1.36.11 (diff)
downloadgentoo-9fba03a74b778758b754512eda6f2ed00a9cd84b.tar.gz
gentoo-9fba03a74b778758b754512eda6f2ed00a9cd84b.tar.bz2
gentoo-9fba03a74b778758b754512eda6f2ed00a9cd84b.zip
dev-python/cfn-lint: Bump to 1.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.20.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 9f94e257665a..1fdb79d2396e 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn_lint-1.18.4.tar.gz 2788919 BLAKE2B c9815d61450d6afa6f054a305b90ceb14a2dd72206834fb64c8e51017cbcf02843dc83e909d1db0dfb183d7f059909a9b794e886745bbe48cac42dcf2c109150 SHA512 fc8ed928fa83d262000c141805734c788559f2ed7ad7b1b989771069cd8972c04dba67a8c4823cceb35ad70db19e28c5f36093cf42f86b232f35eeba8585c89b
DIST cfn_lint-1.20.0.tar.gz 2879582 BLAKE2B da387ad8c8f7425c37106976a9dafe205206559971d847b897e245e283b3cd13179e7033b3e32e0b764b75b1b3d10d23764f84700d4e857fe727a3681b1ff1b2 SHA512 724d1f6ac67d9c1f975f8716d1df1a5ee9f8674a1f3851dad3ad0f5bead8226212012aa3d258ce1cb477904fea6c91c59f6b28291fd846de80fa1c7b3ea1d90f
+DIST cfn_lint-1.20.1.tar.gz 2799223 BLAKE2B 3accc016e5ce688e5e9200247b8d8361c6e367a60c3e8d3de38db079cc6516b50ce6acd773185f89b68b9302ace88eaaf380dbe564b12b43e7b5721509c4e70a SHA512 75d19d65b562737121a4bdca430f177e80a10f685f4cda78c0189ac26fd8bba3c5eee090e8ebd2146f08dbc47d9c24783dce6d89de1ae2712cb2f831e235599e
diff --git a/dev-python/cfn-lint/cfn-lint-1.20.1.ebuild b/dev-python/cfn-lint/cfn-lint-1.20.1.ebuild
new file mode 100644
index 000000000000..55b02df4cc9d
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.20.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.94.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}