summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 16:49:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 17:47:09 -0500
commit86d1954a4a1fc3164a536f38b65229a5000877c7 (patch)
tree89f1b4a55b963efcb7b35bb2c87ee4c6dbbd3faa /dev-python
parentdev-python/python-troveclient: 2.17.0 bump (diff)
downloadgentoo-86d1954a4a1fc3164a536f38b65229a5000877c7.tar.gz
gentoo-86d1954a4a1fc3164a536f38b65229a5000877c7.tar.bz2
gentoo-86d1954a4a1fc3164a536f38b65229a5000877c7.zip
dev-python/python-zaqarclient: 1.11.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-zaqarclient/Manifest1
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-1.11.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/Manifest b/dev-python/python-zaqarclient/Manifest
index 58a0febbf05e..517bcc0a7af2 100644
--- a/dev-python/python-zaqarclient/Manifest
+++ b/dev-python/python-zaqarclient/Manifest
@@ -1 +1,2 @@
+DIST python-zaqarclient-1.11.0.tar.gz 85724 BLAKE2B 84e34998a76bd475b3aad2882f076f8ca89dcfc1a24155d0e88269fda3d82d4b1348461d1f59a5f21726dbc56b37219d9e75957737452e759672505a1f16a4c9 SHA512 4b57cd336a6517760d32a5e01a7c87a9ee0526323a222faa6fcd6e33a506b0746d6418e9eee3fa00e7ba4a01912ee108fe1feb3469e0a14089cc760a0756b7fb
DIST python-zaqarclient-1.2.0.tar.gz 66649 BLAKE2B b1fc054661562b861c39344c73abc8c85fd585b47099a8625ed2a4862997693b793c77698c6147da44affda12cd17d529b5b028d867d5b74400bd7dde13ef4e1 SHA512 1590839460815daa1f0754d47ef789e0c2d2a078265bbb6595eac32114a36c5f15512a2781841955fe99cbdf2cdaa8a13061f535229a284f5b98f97d017dd8a2
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.11.0.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.11.0.ebuild
new file mode 100644
index 000000000000..0e5d438f2bbb
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}