summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:14:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:51:54 +0100
commit83dfad1adc8152e166f43e180384cc4db75bb55c (patch)
treecdc78f6b0621c3f2e0ac1b4a8c788d087045990e /dev-python
parentdev-python/pdm-pep517: Remove old (diff)
downloadgentoo-83dfad1adc8152e166f43e180384cc4db75bb55c.tar.gz
gentoo-83dfad1adc8152e166f43e180384cc4db75bb55c.tar.bz2
gentoo-83dfad1adc8152e166f43e180384cc4db75bb55c.zip
dev-python/trimesh: Bump to 3.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.19.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 87b4d5a60359..5c8fa75c6da9 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -3,3 +3,4 @@ DIST trimesh-3.18.0.gh.tar.gz 12656666 BLAKE2B e183ab1b5ff904b54a7801aaf9e6a3ac2
DIST trimesh-3.18.1.gh.tar.gz 12657109 BLAKE2B 8e5370193e7d47f1dc2d7d43c356df1a56c2b4b8af6f47ac6aa889b04a3b950ec507b5cc0fe6f99f874cf66111aa72773025ba3821013466bb34baced3a361ca SHA512 72936c0fc6f89ffa35b80928dc5abac8ca4fac023f5be1d4adec6d020f3da6ee2c7a97efb0cecf58faad94ef6f33949533ac789affcecee07696ca0188fd47f0
DIST trimesh-3.18.2.gh.tar.gz 12656555 BLAKE2B 39fb1a04a067fdf5e2e85eaacd135f79ae322cab583b1701e702c3638677d8b16d0de411300a39ee39be526500a09ca77fab65666f5eda45c0fa289a48ac1513 SHA512 662034adf97efcc50d0c665b8af5ef190ec48d116186d348d4c431dc1fc51564b36b470d996419770e8f48e2e482e3fa8aa9ced30871c7e1dcb20dcee4e9cd5a
DIST trimesh-3.18.3.gh.tar.gz 12658464 BLAKE2B 8017cc039273fd9bc01605bd80ca0f3b880a138ca81ff1ded862c8083d20f62f0775671260f7f21deeba403bc1a273dd0bbc138779fbf5c1e08bfab9c0937ec3 SHA512 af2838ae8ad01b5113d26aa955a906d6e3379f4484711da1cb76f9735f162a3356b6529e4a633ddb552edb54529c7e738e030d881322d24502e6945e17b55074
+DIST trimesh-3.19.3.gh.tar.gz 12664970 BLAKE2B 4ba302f5ea48253c5bffd9065ab4974d15b7a30cedcf3939d2306ba9db59acb33534918d3303e3cc9444cfff6557544ed16f19a0673a408c17eb056e0ead5d72 SHA512 497e417159a937bc9cbcb92af91ebd346bae67af872fefecf87c9cd3a14e0c9532cd9296ec9eec6653c2bc5c4b95d3a77a56c8235e70fbd940f5c5394ec1b931
diff --git a/dev-python/trimesh/trimesh-3.19.3.ebuild b/dev-python/trimesh/trimesh-3.19.3.ebuild
new file mode 100644
index 000000000000..be6475bba950
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.19.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}