summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 17:11:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 19:26:39 +0200
commite5eb0f82b74a20113eb9c2d881ce68142646563b (patch)
tree298b8dfaf59178fb3ac50a63b3b128cbca4755bb /dev-python/xarray
parentdev-lang/clojure: Stabilize 1.11.3 amd64, #933732 (diff)
downloadgentoo-e5eb0f82b74a20113eb9c2d881ce68142646563b.tar.gz
gentoo-e5eb0f82b74a20113eb9c2d881ce68142646563b.tar.bz2
gentoo-e5eb0f82b74a20113eb9c2d881ce68142646563b.zip
dev-python/xarray: Handle missing dev-python/scipy gracefully
Bug: https://bugs.gentoo.org/933710 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/xarray-2024.5.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2024.5.0.ebuild b/dev-python/xarray/xarray-2024.5.0.ebuild
index 6b80776f042b..208aa7e77af6 100644
--- a/dev-python/xarray/xarray-2024.5.0.ebuild
+++ b/dev-python/xarray/xarray-2024.5.0.ebuild
@@ -48,6 +48,12 @@ python_test() {
EPYTEST_DESELECT+=(
'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
)
+
+ if ! has_version "dev-python/scipy[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT+=(
+ xarray/tests/test_calendar_ops.py::test_interp_calendar
+ )
+ fi
fi
if use big-endian ; then