summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-29 17:47:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-29 17:49:02 +0100
commit69a1299b8fd77d253927394e3f9921822f223a34 (patch)
treea26a0d4bc0a37c089f6c6e6b2a7629cf8d1dbf06 /dev-python/wxpython
parentnet-mail/courier-imap: remove unused patches (diff)
downloadgentoo-69a1299b8fd77d253927394e3f9921822f223a34.tar.gz
gentoo-69a1299b8fd77d253927394e3f9921822f223a34.tar.bz2
gentoo-69a1299b8fd77d253927394e3f9921822f223a34.zip
dev-python/wxpython: Do not hardcode the path to doxygen
Closes: https://bugs.gentoo.org/911925 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/wxpython-4.2.0.ebuild2
-rw-r--r--dev-python/wxpython/wxpython-4.2.1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/wxpython/wxpython-4.2.0.ebuild b/dev-python/wxpython/wxpython-4.2.0.ebuild
index 7488b0c5e8dd..4421e79995df 100644
--- a/dev-python/wxpython/wxpython-4.2.0.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.0.ebuild
@@ -78,7 +78,7 @@ src_configure() {
}
python_compile() {
- DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+ DOXYGEN="$(type -P doxygen)" ${PYTHON} build.py dox etg --nodoc || die
# Refresh the bundled/pregenerated sip files
${PYTHON} build.py sip || die
diff --git a/dev-python/wxpython/wxpython-4.2.1.ebuild b/dev-python/wxpython/wxpython-4.2.1.ebuild
index a609da43141e..db600927b5be 100644
--- a/dev-python/wxpython/wxpython-4.2.1.ebuild
+++ b/dev-python/wxpython/wxpython-4.2.1.ebuild
@@ -71,7 +71,7 @@ src_configure() {
}
python_compile() {
- DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+ DOXYGEN="$(type -P doxygen)" ${PYTHON} build.py dox etg --nodoc || die
# Refresh the bundled/pregenerated sip files
"${EPYTHON}" build.py sip || die