summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-23 09:09:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-23 09:21:09 +0100
commit26f5cb1e5b2f3e084d438541a9afcd0d39594ce8 (patch)
treeeedf7666b123914fbc9e08ca927b6403d884866f /dev-python/wsproto/wsproto-1.0.0.ebuild
parentdev-python/python3-lxc: remove old 3.0.2 (diff)
downloadgentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.tar.gz
gentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.tar.bz2
gentoo-26f5cb1e5b2f3e084d438541a9afcd0d39594ce8.zip
dev-python/wsproto: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsproto/wsproto-1.0.0.ebuild')
-rw-r--r--dev-python/wsproto/wsproto-1.0.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/wsproto/wsproto-1.0.0.ebuild b/dev-python/wsproto/wsproto-1.0.0.ebuild
new file mode 100644
index 000000000000..642751d07b50
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/h11-0.9[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest