summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 18:31:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 19:04:37 +0100
commit162c8bebc9eb51b2f54ccf2fc1968d56aba42b98 (patch)
tree5a3e5919f9725ffbe46925e547f97b509f55d4f7 /dev-python/wheel
parentdev-python/jupyter-core: Bump to 5.5.0 (diff)
downloadgentoo-162c8bebc9eb51b2f54ccf2fc1968d56aba42b98.tar.gz
gentoo-162c8bebc9eb51b2f54ccf2fc1968d56aba42b98.tar.bz2
gentoo-162c8bebc9eb51b2f54ccf2fc1968d56aba42b98.zip
dev-python/wheel: Bump to 0.41.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.41.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index 0de60b397db9..07095c15add6 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1 +1,2 @@
DIST wheel-0.41.2.tar.gz 98050 BLAKE2B 211c3021179e2f80036f57d59583ac449e91558e64fb10cc5b925d93f7288c6db444ca2ac35a20b13a2646641885c094faa458b591554f3bd926c53a3d099ec2 SHA512 46632c2e61f286d33609bc7f954da86c537e4c70b30cb57e79ae8fd5e4422f4fb46dcf2434361d3c6b45b9e5adc6cbf33daa1cd2fc40f31a393162c97ed38356
+DIST wheel-0.41.3.tar.gz 98880 BLAKE2B 3d07d03fabb3c339aecca772fa2229d92893c0fcdffaba726e2be2255f24e728d7d77dc33a03755f01f03e66e8ce098ec6e6d354776c1ee7fe58fa8a02a1e593 SHA512 53fde824b563167825d8f8b5f802bf419f5b1ae823665d27ac8cfe05eee372ea339f8203d1565044c2cae901fe539a2353559351a6a5dafd26c65dde4e2e5eda
diff --git a/dev-python/wheel/wheel-0.41.3.ebuild b/dev-python/wheel/wheel-0.41.3.ebuild
new file mode 100644
index 000000000000..63a78566d3c1
--- /dev/null
+++ b/dev-python/wheel/wheel-0.41.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="
+ https://github.com/pypa/wheel/
+ https://pypi.org/project/wheel/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle packaging
+ rm -r src/wheel/vendored || die
+ sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
+ sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
+
+ distutils-r1_src_prepare
+}