summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 06:58:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 07:32:02 +0100
commitbcd5e03375e8498e754650fdd41b6370c44e9ec1 (patch)
tree77c300ed14a1f6994b2a7c787ff4dbb7e205932a /dev-python/werkzeug
parentdev-python/pysmi: Bump to 1.5.7 (diff)
downloadgentoo-bcd5e03375e8498e754650fdd41b6370c44e9ec1.tar.gz
gentoo-bcd5e03375e8498e754650fdd41b6370c44e9ec1.tar.bz2
gentoo-bcd5e03375e8498e754650fdd41b6370c44e9ec1.zip
dev-python/werkzeug: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-3.1.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index e740bfdc2044..efe0327d9d1e 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-3.0.6.tar.gz 805170 BLAKE2B 7aa02e3e979d9375ec676d02f43738b96410fc3dddf60ca96fc9709790caa47e590952e7675f9226af9f8111271463e82a7069d0ed6e8e672188bc824d3d04a8 SHA512 500f47e13546a3d0ce3a41f21157649571ea70b332ca22758bad939cb42aee4d1b58b64cecc4ed83a857ad466f37de8256cf7b53ad28e5fe0fd353455df3639b
DIST werkzeug-3.1.0.tar.gz 806386 BLAKE2B 7e05da6c4196b30afd0cafeb0fb1c8dcab25a28e78bf8279b2ec639195f4f6296d38d689e085c15a6a53863b210ae7a8bd1c6a4c97d772f8e1bc339369a47160 SHA512 1c1e7f6a2e08aaf5a41f99dd41193cc1177a01242c9281cb7170db84fb193b15a1c3291ef039d8660ac35a89cc6fdf2664f15f742085305a46894f2a2f331976
+DIST werkzeug-3.1.1.tar.gz 806453 BLAKE2B b1b07dcef415d122ca49109fa241fb505193bf990528706508e621f6fc4483ad4ef23ce5830785fd57972fbba0de0e1a92e6b1035622d63e22ec622869168de5 SHA512 abae534907959d8d1032f5c99a241c74785ede89a7f8cd760dcbed07d77bbb92167db75cc8f212a5e635ce8d473b82a3b3d5cc89ecf9c068bb7f2e6f7d7fe9b7
diff --git a/dev-python/werkzeug/werkzeug-3.1.1.ebuild b/dev-python/werkzeug/werkzeug-3.1.1.ebuild
new file mode 100644
index 000000000000..886c4e4621ba
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xprocess-1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xprocess -p timeout tests
+}