summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-05 02:24:56 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-05 20:52:35 +0200
commita8fa5fd7d0dd55197ac350a46fcce7be88c6f39e (patch)
treeb4c1e8aea7010d49f92161feec2cd24793f11cfd /dev-python/websockets
parentdev-python/denonavr: enable py3.10 (diff)
downloadgentoo-a8fa5fd7d0dd55197ac350a46fcce7be88c6f39e.tar.gz
gentoo-a8fa5fd7d0dd55197ac350a46fcce7be88c6f39e.tar.bz2
gentoo-a8fa5fd7d0dd55197ac350a46fcce7be88c6f39e.zip
dev-python/websockets: enable py3.10 via backported patch
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-9.1-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 91482ee75fcc..e6d188555429 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1 +1,2 @@
+DIST websockets-9.1-python-3.10-support.patch.gz 6940 BLAKE2B e4835c7d5efaf956d07b884c85e0b95f26674bf36164fa8362d1c1a564a959bde761d25e747333c58864f74a5ea1b199f228a46ec6a1647c5495ea032020c179 SHA512 7fb4b298a9167c8d913e293fa7549b21d5acb333a5b97e0624a22cb83548ef548b819ac23750c40295140b6f83a701c73a81fdcaed3ab8e704dbee8e17d22f1d
DIST websockets-9.1-src.tar.gz 191813 BLAKE2B cb3807f01e1a4c22a40bf5150d1e8b21ca786dc5bc4da8f3e6602971f3f7c79b57092f5ddfe3ee52ec00e7fd15f3a992fdbb94b5e26599f2621a7f51434ba6dd SHA512 ff2907a913ff0b8ced6dda72b6fc6512a2ece3ffded2e2dcb8ff6805de9ad504430cc1871c1f6e02ab8069e7b96b2e7609afaf3c9c25f9271b28e2daa72bd3ac
diff --git a/dev-python/websockets/websockets-9.1-r1.ebuild b/dev-python/websockets/websockets-9.1-r1.ebuild
new file mode 100644
index 000000000000..4fe1b8159c40
--- /dev/null
+++ b/dev-python/websockets/websockets-9.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="
+ https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz
+ https://dev.gentoo.org/~sbraz/${P}-python-3.10-support.patch.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # https://github.com/aaugustin/websockets/commit/08d8011132ba038b3f6c4d591189b57af4c9f147
+ "${WORKDIR}/${P}-python-3.10-support.patch"
+)
+
+src_prepare() {
+ # these fail due to timeouts on slower hardware
+ sed -e 's:test_keepalive_ping_with_no_ping_timeout:_&:' \
+ -e 's:test_keepalive_ping(:_&:' \
+ -i tests/legacy/test_protocol.py || die
+
+ distutils-r1_src_prepare
+}