summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-09 20:13:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-09 21:46:47 +0200
commit4f77e67aac446c4a14fc0e5615423f2fc66a0efd (patch)
tree0656ee3f6f224383f7aeff24f1584db29a3c5d8f /dev-python/webcolors
parentdev-python/rfc3987: Port to py3.9 (diff)
downloadgentoo-4f77e67aac446c4a14fc0e5615423f2fc66a0efd.tar.gz
gentoo-4f77e67aac446c4a14fc0e5615423f2fc66a0efd.tar.bz2
gentoo-4f77e67aac446c4a14fc0e5615423f2fc66a0efd.zip
dev-python/webcolors: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webcolors')
-rw-r--r--dev-python/webcolors/webcolors-1.10.ebuild5
-rw-r--r--dev-python/webcolors/webcolors-1.11.1.ebuild2
2 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/webcolors/webcolors-1.10.ebuild b/dev-python/webcolors/webcolors-1.10.ebuild
index 4fd92f81edcf..d16c23c3814e 100644
--- a/dev-python/webcolors/webcolors-1.10.ebuild
+++ b/dev-python/webcolors/webcolors-1.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
inherit distutils-r1
@@ -15,7 +15,6 @@ SLOT="0"
LICENSE="BSD"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/six[${PYTHON_USEDEP}]"
distutils_enable_tests nose
diff --git a/dev-python/webcolors/webcolors-1.11.1.ebuild b/dev-python/webcolors/webcolors-1.11.1.ebuild
index 59a073dd61ca..d59f5a1b988e 100644
--- a/dev-python/webcolors/webcolors-1.11.1.ebuild
+++ b/dev-python/webcolors/webcolors-1.11.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1