summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-02-28 17:16:58 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-02-28 17:18:22 +0100
commit07674a0008e7763749f0d16a5ff8b4c5729741b0 (patch)
tree49f88fce0d89faa4afd440ca856cfea26d745dc2 /dev-python/wand/wand-0.6.6.ebuild
parentnet-misc/socket-burst-dampener: Bump to version 1.3.0 (diff)
downloadgentoo-07674a0008e7763749f0d16a5ff8b4c5729741b0.tar.gz
gentoo-07674a0008e7763749f0d16a5ff8b4c5729741b0.tar.bz2
gentoo-07674a0008e7763749f0d16a5ff8b4c5729741b0.zip
dev-python/wand: bump to 0.6.6
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/wand/wand-0.6.6.ebuild')
-rw-r--r--dev-python/wand/wand-0.6.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wand/wand-0.6.6.ebuild b/dev-python/wand/wand-0.6.6.ebuild
new file mode 100644
index 000000000000..7c72b4e84647
--- /dev/null
+++ b/dev-python/wand/wand-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ pytest -vv --skip-pdf || die "Tests fail with ${EPYTHON}"
+}