summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-11 04:52:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-11 04:52:26 +0200
commit2071bc2e5e0842b959326975760660dd09719c04 (patch)
treef94f457101864c19e686b9a537a1959bb2bc6192 /dev-python/typeguard
parentdev-python/hypothesis: Bump to 6.84.3 (diff)
downloadgentoo-2071bc2e5e0842b959326975760660dd09719c04.tar.gz
gentoo-2071bc2e5e0842b959326975760660dd09719c04.tar.bz2
gentoo-2071bc2e5e0842b959326975760660dd09719c04.zip
dev-python/typeguard: Bump to 4.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.1.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index cc07b0a86b16..2def9a5675dc 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1,2 +1,3 @@
DIST typeguard-4.1.0.tar.gz 67584 BLAKE2B d2f6777cad306410d4a536312a981600371e0e0cae224eee286e3b6bd48a0777ca587eb44b4f48fd9a2c7fe5e35d274f5d1c2eb508ed9708b25b686b395976fb SHA512 5a1a374c1b9679cf1d840a750698caea47deae0fcec8eda3312773fd8eee8ccc533030b78c8e1c8bfae6bee79c323ba421176b2c8d2e85a87444ba767891ede7
DIST typeguard-4.1.3.tar.gz 67821 BLAKE2B 66373b95f9f3c995ad560f4f35318647a6dd8581b1b7ad1a4adbc3f4944a7ca130cc3291d12b062b3c0d05f82ad254249a80ececa5984f4d16fd093deeecc1fb SHA512 bf9914ac33b3c7afb439e96c9319f79ee67591d3bfa7da1f0df50ba7b2bbaf0c3705d45d9fe7215b132f838f4d57ae2c0abe1f4b90c4199520601453d2ca04f8
+DIST typeguard-4.1.4.tar.gz 68958 BLAKE2B 92147b2d8e2c444d4e8085ebe337aee4e1be771678ef84c7fca14aef8a3b18c51dd694948fa0b0a4c3bfa1a6e1c11fe38d1990cd734cfbc358a8a54a731e018a SHA512 fc1b8c154d3e26f83241eda5e7781a8d09ac7cb5d5da5809bebf40db7a1691afe008384bdaafbfca4f3eb619e452c8bb841d5691e90bcabb95ab00b710d03c98
diff --git a/dev-python/typeguard/typeguard-4.1.4.ebuild b/dev-python/typeguard/typeguard-4.1.4.ebuild
new file mode 100644
index 000000000000..2d5d1842fcbf
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.7.0[${PYTHON_USEDEP}]
+ ' 3.{10..11})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False
+}