summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 07:20:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 07:20:31 +0200
commit1a55855041a8ffe0d7d2f4be54d42f6766a0902f (patch)
tree06039c561963dc950cf2056b7cb173247396cad3 /dev-python/trimesh
parentdev-python/networkx: Bump to 3.1 (diff)
downloadgentoo-1a55855041a8ffe0d7d2f4be54d42f6766a0902f.tar.gz
gentoo-1a55855041a8ffe0d7d2f4be54d42f6766a0902f.tar.bz2
gentoo-1a55855041a8ffe0d7d2f4be54d42f6766a0902f.zip
dev-python/trimesh: Bump to 3.21.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.21.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 834629ce0de7..aff08a6e92e1 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -4,3 +4,4 @@ DIST trimesh-3.21.0.gh.tar.gz 12688064 BLAKE2B 5ac8c4cd3f087b63ad6e224a693380a7f
DIST trimesh-3.21.1.gh.tar.gz 12689151 BLAKE2B e0d04a6003656f096404ec8972907381f5950f7a6ac3864963fc9a52dc015ad42d39e88ced8d125f725333ddde722358ebac9f263fda0cd21d663af42318bd50 SHA512 08716a310db8cae86a725072a6626b3703ffac3532182ce22389cf85fcdf5853ad8f17cfd8c34afde0e6dc0f2125d910d130810c3cce8e8dcb1605737074a3e0
DIST trimesh-3.21.2.gh.tar.gz 12691646 BLAKE2B 0ec2c1e9afb607984b92d339fa07dd8b92bf0ac50c56704c98ce3f6c35449794b595640d68c67dc2ce59f236545f5df72238aef21103fbc1f432bbe285332a46 SHA512 e9e692c6dd20c787c9262e148aaaffb81c8ef3decbeb16e3c008a585701e9e71c73487e8226b159e86d550019f297bb2163b3be3006dd08c2df932d3dcd0b403
DIST trimesh-3.21.3.gh.tar.gz 12692861 BLAKE2B 8e3f9cc28b26371bc46b31c48c1e79345cb6f27755999bf99cc793f83706ab559cffb3788101995550e112b77617c0d112c06f636f0f4c3047b966f669b419b3 SHA512 ab72b8b61643152d5fdcf5326b1c8a6f8e54c4bbc0653fe8c1dd379ecfa8510ae542c85adde8200abcb863ec80dbeb9046d6d7d4ec5f1f9aadead8871841b948
+DIST trimesh-3.21.4.gh.tar.gz 12692752 BLAKE2B 47f83c594318270c1594bad9c877de2cba71d44eccae7f755418aba785ce21c36946e482b38020a79417c4e346cd60cf3b31ee96bd489501a9dd88c2d433c68c SHA512 749f208b91f55b2a9581fa953bd984fc71a7c54bcc3d00ad1df8af2489911e966d2821dcff3d673e8ba55a83c9cce75625aaaeeddff817a16bb09b82b2bca549
diff --git a/dev-python/trimesh/trimesh-3.21.4.ebuild b/dev-python/trimesh/trimesh-3.21.4.ebuild
new file mode 100644
index 000000000000..c876396fccaa
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.21.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}