summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-07 20:47:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-07 21:30:05 +0100
commit041a4109e50957e49871aea45831d433f28fcaa5 (patch)
tree9fd588602831c34a03b806e9b804254b4fb2632c /dev-python/tomlkit
parentdev-python/fs: Bump to 2.4.15 (diff)
downloadgentoo-041a4109e50957e49871aea45831d433f28fcaa5.tar.gz
gentoo-041a4109e50957e49871aea45831d433f28fcaa5.tar.bz2
gentoo-041a4109e50957e49871aea45831d433f28fcaa5.zip
dev-python/tomlkit: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.9.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 128b84c80e3d..7179b5ed43fc 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
DIST tomlkit-0.8.0.tar.gz 179067 BLAKE2B 871eb8371d94c76552d78a56adfbde5ebb9da4b93aa29229ae9aa279ae35fac488a1b4986169b818d2e5366883b8f246b44dc9075d0d9785b2d7d6f97e222ec1 SHA512 77b267201021e740d8134d0d5edfbef2cf077adac0b320d80887fdedda3f63f74df1957e8230976f16c80fcc58fd4cfabb195cccf0eda7d6cd29f5f65d362147
DIST tomlkit-0.9.0.tar.gz 176037 BLAKE2B 2301b1c9d28eeb595b0580ae4172b0c044a67c75b417b0a004af2afa5bb4bddb07a73e8cdc2949008efa024ab603e44e43d830453827e02d2b7a4483cc360dc3 SHA512 36cb7fd683b4dc6e82a4828db76ad997de79302ed485751b14375e7483400adbce8e9b8bf913a6f404ffc16a06cf90158caca20c4419bd032a7d27a8790573db
+DIST tomlkit-0.9.1.tar.gz 176273 BLAKE2B 99a7fff43a23b386e6570b52a34eaf599c1507d41fdf7ee068d8b545ee28ef4ce560a255c14008ee5d90f7b580a04c6c29b3a44767e10c25caf9fe19df029d20 SHA512 7c9a8d5fd9550cb23f90f6ed627f957fdfe29397be0a99b4b0f68767cee268343ebd8a4f8977b9a0f84573ce7e49116874ad1d1af419b86ee41bab0efbfdf400
diff --git a/dev-python/tomlkit/tomlkit-0.9.1.ebuild b/dev-python/tomlkit/tomlkit-0.9.1.ebuild
new file mode 100644
index 000000000000..4de45e362c79
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}