summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-22 16:22:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-22 16:45:34 +0100
commit5b18cd06af19e44c206b36f11834ac1e202d2851 (patch)
treecb2d8b7f1a5d776d3c00b4aad1c95fa49dc2449b /dev-python/textdistance
parentxfce-base/xfce4-settings: Bump to 4.18.1 (diff)
downloadgentoo-5b18cd06af19e44c206b36f11834ac1e202d2851.tar.gz
gentoo-5b18cd06af19e44c206b36f11834ac1e202d2851.tar.bz2
gentoo-5b18cd06af19e44c206b36f11834ac1e202d2851.zip
dev-python/textdistance: Remove unused test dependencies
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/textdistance-4.5.0.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/textdistance/textdistance-4.5.0.ebuild b/dev-python/textdistance/textdistance-4.5.0.ebuild
index 5f557cf3b372..4af20c362ea5 100644
--- a/dev-python/textdistance/textdistance-4.5.0.ebuild
+++ b/dev-python/textdistance/textdistance-4.5.0.ebuild
@@ -5,13 +5,18 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Compute distance between the two texts"
-HOMEPAGE="https://github.com/life4/textdistance"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
SRC_URI="
https://github.com/life4/textdistance/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -19,17 +24,13 @@ KEYWORDS="amd64 ~ppc64 ~riscv x86"
BDEPEND="
test? (
- dev-python/abydos[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/isort[${PYTHON_USEDEP}]
- dev-python/jellyfish[${PYTHON_USEDEP}]
- dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
+EPYTEST_IGNORE=(
tests/test_external.py
)