summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 23:37:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 23:42:16 +0100
commitde60aec46bd43701e10d66cb6d83d56acd5ad785 (patch)
tree4bb5b7ba5043fec9a6c4aaee3b3eae73314639c0 /dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild
parentmedia-gfx/prusaslicer: fix build with cereal-1.3.1 (diff)
downloadgentoo-de60aec46bd43701e10d66cb6d83d56acd5ad785.tar.gz
gentoo-de60aec46bd43701e10d66cb6d83d56acd5ad785.tar.bz2
gentoo-de60aec46bd43701e10d66cb6d83d56acd5ad785.zip
dev-python/text-unidecode: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild')
-rw-r--r--dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild b/dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild
new file mode 100644
index 000000000000..97c613f06659
--- /dev/null
+++ b/dev-python/text-unidecode/text-unidecode-1.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The most basic port of the Text::Unidecode Perl library"
+HOMEPAGE="
+ https://pypi.org/project/text-unidecode/
+ https://github.com/kmike/text-unidecode/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest