summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 07:59:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 08:48:38 +0100
commitd9ee5fee9ee87acc1d73d59e861360392be3a044 (patch)
tree746a8572a9ac6eb3204aaad6d77ddb2e29495db4 /dev-python/sybil
parentdev-python/pebble: Bump to 5.0.4 (diff)
downloadgentoo-d9ee5fee9ee87acc1d73d59e861360392be3a044.tar.gz
gentoo-d9ee5fee9ee87acc1d73d59e861360392be3a044.tar.bz2
gentoo-d9ee5fee9ee87acc1d73d59e861360392be3a044.zip
dev-python/sybil: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 0ef57f81a096..6be0e9543072 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
+DIST sybil-6.0.0.gh.tar.gz 67505 BLAKE2B b7408802d5f6796701603762f1e48dbd2f218b5ae80fad940f1ba1fdf0643d1f16cb0a88d94b6385f6ff47d4ab18463be613f736613fa5f0baa3f9ff056ebfa8 SHA512 a03cb7e874a6a41f41ca21e9110f0b8f0d45bb94a5cd7c4f0eb0528ce01db4ac9ca6d8d84663d8851c01dda5da3cb232bcadb33594c5c10e5775f390db37ee9a
diff --git a/dev-python/sybil/sybil-6.0.0.ebuild b/dev-python/sybil/sybil-6.0.0.ebuild
new file mode 100644
index 000000000000..38d5f40dd52e
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest