summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-01 16:50:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-01 17:44:01 +0200
commitb6dcd687ef6f14dc85c0a6b34dd814d7943d96ff (patch)
tree3fa643da0ff195d1125a0193cb1b546dea855217 /dev-python/statsd
parentwww-client/chromium: fix stable channel to build with icu-67.1 (diff)
downloadgentoo-b6dcd687ef6f14dc85c0a6b34dd814d7943d96ff.tar.gz
gentoo-b6dcd687ef6f14dc85c0a6b34dd814d7943d96ff.tar.bz2
gentoo-b6dcd687ef6f14dc85c0a6b34dd814d7943d96ff.zip
dev-python/statsd: Add missing test dep, py3.8, modernize
Closes: https://bugs.gentoo.org/720096 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/statsd')
-rw-r--r--dev-python/statsd/statsd-3.3.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/statsd/statsd-3.3.0.ebuild b/dev-python/statsd/statsd-3.3.0.ebuild
index f92fe942f384..cd01b37d821d 100644
--- a/dev-python/statsd/statsd-3.3.0.ebuild
+++ b/dev-python/statsd/statsd-3.3.0.ebuild
@@ -2,28 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
DESCRIPTION="A simple statsd client"
HOMEPAGE="https://github.com/jsocol/pystatsd https://pypi.org/project/statsd"
-
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
)"
-python_test() {
- nosetests --verbose || die
-}
+distutils_enable_tests nose