summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 23:13:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 23:13:14 +0100
commit006e63025aaa630b6a85a1ab38d6baa1ab37310d (patch)
treeab61af8ed1b53ec091e9d19440d7a2cb9685c873 /dev-python/sphinxcontrib-spelling
parentdev-python/pycryptodome: Bump to 3.12.0 (diff)
downloadgentoo-006e63025aaa630b6a85a1ab38d6baa1ab37310d.tar.gz
gentoo-006e63025aaa630b6a85a1ab38d6baa1ab37310d.tar.bz2
gentoo-006e63025aaa630b6a85a1ab38d6baa1ab37310d.zip
dev-python/sphinxcontrib-spelling: Bump to 7.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index d45724a9cd9a..9bd0c65c6c40 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-7.2.1.tar.gz 49584 BLAKE2B 7211acfe344b157c0d44f356aef4c31fabcb1b30256cec1693fa67d2652d80c8f3657441c193f82ef26e0e7acd7d141732bef0704462a292355d70a18ab3c2be SHA512 e9b9709b627545e1191d64753c97c0cf65e100d5379e7cc1da46faf9c5d5ea0eeb6c7aafe99331f9518488fb0801c245e0c1fa9853360bb6cf373515a4fed2ed
+DIST sphinxcontrib-spelling-7.3.0.tar.gz 49853 BLAKE2B 3bf7c6433a5de6b109891f1546f109ce7dc5870c0932f49a2dfbc1356c365ba48f885af21e0873284112d8b7b67dbb24730373a16e6786ba7e15f2bc23dc8360 SHA512 25b1902547e4ed172ec437aca0868f458c60aab8dacbeeec7ec1c57a93716672986b815aadb9c129fc6b068b5e4d7e96f6200160c0b688e67314abf290e4ff17
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild
new file mode 100644
index 000000000000..1bbda9a87600
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+# The doc can only be built from a git repository
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_filter.py::test_contributors
+)
+
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}