summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-01 22:13:48 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:23 +0000
commit5fae0670903bc4b1541e6cb7e8e3375989eca6ce (patch)
tree2f3e75eefe0517bf1750f2ab09fb99966c7f8698 /dev-python/sphinxcontrib-asyncio
parentdev-util/drone-cli: Remove old (diff)
downloadgentoo-5fae0670903bc4b1541e6cb7e8e3375989eca6ce.tar.gz
gentoo-5fae0670903bc4b1541e6cb7e8e3375989eca6ce.tar.bz2
gentoo-5fae0670903bc4b1541e6cb7e8e3375989eca6ce.zip
dev-python/sphinxcontrib-asyncio: fix namespace conflict, remove inexistent tests
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..fe969fc8bbac
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+ # clean up pth files bug #623852
+ find "${ED}" -name '*.pth' -delete || die
+ # collision bug #625872
+ _namespace_cleanup() {
+ rm "${D%/}"$(python_get_sitedir)/sphinxcontrib/__init__.py || die
+ }
+ python_foreach_impl _namespace_cleanup
+}