summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 11:56:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 11:56:41 +0100
commit109452dc51a25e7b1bfbdcab6df563d50ec9a1bd (patch)
treeb17398b66aa9cea9c807afd8f85ac21826547fb4 /dev-python/sphinx
parentdev-python/python-docs: Readd stable hppa keywords (diff)
downloadgentoo-109452dc51a25e7b1bfbdcab6df563d50ec9a1bd.tar.gz
gentoo-109452dc51a25e7b1bfbdcab6df563d50ec9a1bd.tar.bz2
gentoo-109452dc51a25e7b1bfbdcab6df563d50ec9a1bd.zip
dev-python/sphinx: Add min versions of dependencies
Reported by Dakon. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/sphinx-3.3.1-r1.ebuild (renamed from dev-python/sphinx/sphinx-3.3.1.ebuild)14
-rw-r--r--dev-python/sphinx/sphinx-3.4.0-r1.ebuild (renamed from dev-python/sphinx/sphinx-3.4.2.ebuild)12
-rw-r--r--dev-python/sphinx/sphinx-3.4.1-r1.ebuild (renamed from dev-python/sphinx/sphinx-3.4.0.ebuild)14
-rw-r--r--dev-python/sphinx/sphinx-3.4.2-r1.ebuild (renamed from dev-python/sphinx/sphinx-3.4.1.ebuild)14
4 files changed, 27 insertions, 27 deletions
diff --git a/dev-python/sphinx/sphinx-3.3.1.ebuild b/dev-python/sphinx/sphinx-3.3.1-r1.ebuild
index 1d28fd613269..5345aa624ca7 100644
--- a/dev-python/sphinx/sphinx-3.3.1.ebuild
+++ b/dev-python/sphinx/sphinx-3.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,13 +22,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
<dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
dev-python/imagesize[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
diff --git a/dev-python/sphinx/sphinx-3.4.2.ebuild b/dev-python/sphinx/sphinx-3.4.0-r1.ebuild
index ca0c81f75165..5c5fee0c30b8 100644
--- a/dev-python/sphinx/sphinx-3.4.2.ebuild
+++ b/dev-python/sphinx/sphinx-3.4.0-r1.ebuild
@@ -22,13 +22,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
<dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
dev-python/imagesize[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
diff --git a/dev-python/sphinx/sphinx-3.4.0.ebuild b/dev-python/sphinx/sphinx-3.4.1-r1.ebuild
index f99a4152883e..5c5fee0c30b8 100644
--- a/dev-python/sphinx/sphinx-3.4.0.ebuild
+++ b/dev-python/sphinx/sphinx-3.4.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,13 +22,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
<dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
dev-python/imagesize[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
diff --git a/dev-python/sphinx/sphinx-3.4.1.ebuild b/dev-python/sphinx/sphinx-3.4.2-r1.ebuild
index f99a4152883e..5c5fee0c30b8 100644
--- a/dev-python/sphinx/sphinx-3.4.1.ebuild
+++ b/dev-python/sphinx/sphinx-3.4.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,13 +22,13 @@ RESTRICT="!test? ( test )"
RDEPEND="
<dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
dev-python/imagesize[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]