summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-08 21:17:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-08 21:26:59 +0100
commit8e9fde07bd06d23df9813e6ad115f67f8a8bfa09 (patch)
tree8a61b55618a3c1f1e911e09012aed7c1056486ed /dev-python/simsimd
parentdev-python/blinker: Bump to 1.9.0 (diff)
downloadgentoo-8e9fde07bd06d23df9813e6ad115f67f8a8bfa09.tar.gz
gentoo-8e9fde07bd06d23df9813e6ad115f67f8a8bfa09.tar.bz2
gentoo-8e9fde07bd06d23df9813e6ad115f67f8a8bfa09.zip
dev-python/simsimd: Bump to 6.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simsimd')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-6.0.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index bfe3355c1db6..40b77ce5a6df 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,3 +1,4 @@
DIST SimSIMD-5.9.11.gh.tar.gz 204255 BLAKE2B 6c67f47bf2beb41b8f6e091874c808a9be0da307d6bc7af5d6cca62435d1a4199cff7444b8b9f0ce04dbdd779641d635b8e7545512cfeb782ca81ef0f6e74e2e SHA512 eae6b0a509198de09a6d47c207554cc330ad1242b3a1d98d74d0fcb0c960052de1765e05d2bbe4bbb295224266dc393890a159b7fa933c6d7725685a5e50d1ec
DIST SimSIMD-6.0.0.gh.tar.gz 206367 BLAKE2B a79d19ffd4fb9fb518ec4b05523aa316e99e1729884decfe560be419ab7dd5d8395835ebcd593dc7ec92aa8524ce2a6f1a3693e363c638d60d1d417b636f1fbe SHA512 0edc66409d6616066205b6f976220a86f180f3e1d32c2a25e9173ae49314ed72362949bcc91b288e791b65569654573e7b3b9a5f1c79609ab58ada12abe8a458
DIST SimSIMD-6.0.1.gh.tar.gz 206464 BLAKE2B db6806c21920531c8e108b6a7b393a79a7ed90fdda0bae7e59254298b93b3aa2fcedaf39eab1c1ea81a2c4e9cd813def898e9313220518f6e1c4586b41fa6fc2 SHA512 889fd41365f978c236d8ddc33600f02839f7169cca26f18bc45322c167e56ae21a15a7ff1e8d51b47f70066a8b2611ae23c5be2f9897a6287690613d3e6e33dc
+DIST SimSIMD-6.0.2.gh.tar.gz 206774 BLAKE2B 659cd0e5c3a097fa614b8d82fdbdf6d955dee52370351c6b68af5931b0be45773caf77fe1a092d28edaa8490d23a352303801e85e85d46a1bbbdcf8d33955683 SHA512 bbb005845bce900beca5e9f76ba7a16e7dec134c1bb7eaccba07602143aae7f84bb0de5c0a09ef7c6b79ca3d50b8a505ca072af7dd47096c56e80943c6723e23
diff --git a/dev-python/simsimd/simsimd-6.0.2.ebuild b/dev-python/simsimd/simsimd-6.0.2.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-6.0.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}