summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-22 10:10:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-22 10:22:13 +0200
commit579e4e7e1b98cd5e6ebfc8a0e8f97847dbfe646e (patch)
treec6809ce68ef5172b3647f96677aa2bf656551e5f /dev-python/sentry-sdk
parentsci-libs/libh2o: Remove static-libs (diff)
downloadgentoo-579e4e7e1b98cd5e6ebfc8a0e8f97847dbfe646e.tar.gz
gentoo-579e4e7e1b98cd5e6ebfc8a0e8f97847dbfe646e.tar.bz2
gentoo-579e4e7e1b98cd5e6ebfc8a0e8f97847dbfe646e.zip
dev-python/sentry-sdk: Bump to 0.17.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.17.7.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index c49f15bd3882..1cef97c52695 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,2 +1,3 @@
DIST sentry-sdk-0.16.3.tar.gz 170145 BLAKE2B bf619313fb3f49800f5384f0dfec3aa34ef4bb030c5e038a485a8861a733a537ee7c834c8c200a2244335c3c61e7d564005b81d4e5c5f603d2864b2a943a5384 SHA512 e8589f7bd433d4aff068099e860c0cf012fc88dc63806873573a338bb91848d73e0a2af76dad0a5e023a1b25b0be85507346b77dec5c5a265942005219541699
DIST sentry-sdk-0.17.6.tar.gz 183157 BLAKE2B ea0f6af54c31abc785274fc75238a02b8c9f7a978881a01203e0928e100c18df2257ec4a3cef608141b6846c616566388134a4ec31364f26d0bc2b0fadbb0dac SHA512 1af433b5c2311612ad650ea196ddfedb444e9ccb424df72422759f8647fe6cc22bb81a15933f2716cf40313ce3b2e262c077168aa831758d057a1f2e5e1499ff
+DIST sentry-sdk-0.17.7.tar.gz 184034 BLAKE2B de71b2e270594abe2e16d7e2fb9db3028e3c2abd4539269562e8786e6d937352153da21d6366d5e0384e3de1dbd6fbabe3d5060a6f0f9953bd260fbd865c893d SHA512 2360321ec0231ba76c968ff4e6dc78d42a48106aa6aade73a1c1194f9406fbafea3b533994da42027b3479302756ed3ec6e44ce551cb01ce60397939beaeb6d4
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.17.7.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.17.7.ebuild
new file mode 100644
index 000000000000..1e52e8d55106
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.17.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ <dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/aiocontextvars[${PYTHON_USEDEP}]
+ dev-python/contextvars[${PYTHON_USEDEP}]
+ ' python3_6)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ --deselect tests/integrations/stdlib/test_httplib.py
+ --deselect tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ --deselect tests/integrations/gcp/test_gcp.py
+ # fails on py3.6, hangs on py3.7+
+ --deselect
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ --deselect
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ --deselect
+ tests/test_client.py::test_databag_depth_stripping
+ --deselect
+ tests/test_client.py::test_databag_string_stripping
+ --deselect
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_filename: apparently unhappy about pytest being called pytest
+ --deselect 'tests/utils/test_general.py::test_filename'
+ # test_circular_references: apparently fragile
+ --deselect
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ )
+ [[ ${EPYTHON} == python3.6 ]] && deselect+=(
+ # broken with contextvars on py3.6
+ --deselect
+ 'tests/utils/test_contextvars.py::test_leaks[greenlet]'
+ --deselect
+ 'tests/test_transport.py::test_transport_works[greenlet'
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}