summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-04-29 20:33:09 -0400
committerJoonas Niilola <juippis@gentoo.org>2023-05-20 15:50:06 +0300
commit1cf2656a5d354a18d4b22cc295ef269d71ba0dc8 (patch)
treec3ae4da563d0f9736d918530cbe3a292033485fe /dev-python/sabyenc
parentx11-misc/stalonetray: update EAPI 7 -> 8 (diff)
downloadgentoo-1cf2656a5d354a18d4b22cc295ef269d71ba0dc8.tar.gz
gentoo-1cf2656a5d354a18d4b22cc295ef269d71ba0dc8.tar.bz2
gentoo-1cf2656a5d354a18d4b22cc295ef269d71ba0dc8.zip
dev-python/sabyenc: add 7.0.2
Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/30809 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/sabyenc')
-rw-r--r--dev-python/sabyenc/Manifest1
-rw-r--r--dev-python/sabyenc/sabyenc-7.0.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sabyenc/Manifest b/dev-python/sabyenc/Manifest
index c67cf31c6268..57da4ecce1a9 100644
--- a/dev-python/sabyenc/Manifest
+++ b/dev-python/sabyenc/Manifest
@@ -1 +1,2 @@
+DIST sabctools-7.0.2.gh.tar.gz 8539819 BLAKE2B 38212656c745238f106fbc9334f6dccb02bb9e05153bc73a21a783a25a0c5a63cae2893a01fcceefe37e6f5f187fc6d762fcc632f1228410e951740c808e0e9e SHA512 05968a29afb7a041549bae9e9a4303160820da4cd10ea33ab4475fe48fd0b4cf46023c6254715161265f3e1bdf2b66ae7e62007789fbc288aa229d3a218a3df8
DIST sabyenc-5.4.4.gh.tar.gz 19774441 BLAKE2B 945614697b59f984df1f159b64e177ee75d9b5c00cb59af21dddb92bf17f8647467b919be963a1beabfe64c4206aa6f3438b780a21e766722fad99afa38ea340 SHA512 a35a5f29b1f5586299fdfd87d4323fa8ab56f06a2f6ef3b0b95aa033a481beee886bf1834ed73e1ba65b74c5e86efc5f0307394f32803ef52a391ca4b0caedf9
diff --git a/dev-python/sabyenc/sabyenc-7.0.2.ebuild b/dev-python/sabyenc/sabyenc-7.0.2.ebuild
new file mode 100644
index 000000000000..74dc4d02eef7
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-7.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabctools"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest