summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 16:20:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 17:18:15 +0200
commitef88faa987c0af04e85d8d7844c608ec11edb19a (patch)
treeeb24b757018bb696d48e3fc0d26dbd709fc06d7f /dev-python/rospkg
parentdev-ros/cmake_modules: bump to 0.5.0 (diff)
downloadgentoo-ef88faa987c0af04e85d8d7844c608ec11edb19a.tar.gz
gentoo-ef88faa987c0af04e85d8d7844c608ec11edb19a.tar.bz2
gentoo-ef88faa987c0af04e85d8d7844c608ec11edb19a.zip
dev-python/rospkg: bump to 1.2.6; drop pypy
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.2.6.ebuild50
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild2
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 3d7146dfd9e0..2ad08e490359 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.2.0.tar.gz 90516 BLAKE2B 0c1d993c70f0ad383ab457c846416a22b9adf9611704a918c3765659231846749228073ea04950ddfdbe13f7e51f87ce5d17c1488f995e846a6590a0f9549efd SHA512 f059259a38b8b2281496a69f8a55fdd31a11e91583babb82e574363c40c90221a4abb7c1d7a5ed6be3b2389ee6aaf08b4e016260c73dd779f8c7993e6eba78db
+DIST rospkg-1.2.6.tar.gz 90944 BLAKE2B 26bd4a9deb3c6876b870ec6ccb11dfdb7820d0cf23fef2fcea8391543c58cf8e916253316df443cc9cc7e364ab790a8915e77986aef3f400785f50604fbd2a45 SHA512 6c88c8789927d72f8f882930aeef776dbec3c4d1343a2d4143d920684c8d2007021397a42008521c87dfc637302b9266615e13623ef5dc5c076e6e8cfd9e957d
diff --git a/dev-python/rospkg/rospkg-1.2.6.ebuild b/dev-python/rospkg/rospkg-1.2.6.ebuild
new file mode 100644
index 000000000000..3dd32f0afe6f
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" "${FILESDIR}/yaml_load.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index d3245f8cb2a1..3dd32f0afe6f 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+PYTHON_COMPAT=( python{3_6,3_7} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then