summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-22 11:02:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-22 11:25:46 +0200
commitb2cf8f7aeefadeb4fbd8c3f5508005037a10e334 (patch)
treeaadf0c90c48c3b36e81e78736a13add6a5c61418 /dev-python/requests-unixsocket
parentdev-vcs/git-pw: update EAPI 7 -> 8, python3.10 support (diff)
downloadgentoo-b2cf8f7aeefadeb4fbd8c3f5508005037a10e334.tar.gz
gentoo-b2cf8f7aeefadeb4fbd8c3f5508005037a10e334.tar.bz2
gentoo-b2cf8f7aeefadeb4fbd8c3f5508005037a10e334.zip
dev-python/requests-unixsocket: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-unixsocket')
-rw-r--r--dev-python/requests-unixsocket/requests-unixsocket-0.3.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/requests-unixsocket/requests-unixsocket-0.3.0-r2.ebuild b/dev-python/requests-unixsocket/requests-unixsocket-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..ee715c0c7d77
--- /dev/null
+++ b/dev-python/requests-unixsocket/requests-unixsocket-0.3.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Use requests to talk HTTP via a UNIX domain socket"
+HOMEPAGE="
+ https://github.com/msabramo/requests-unixsocket/
+ https://pypi.org/project/requests-unixsocket/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/waitress[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest