summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 13:26:47 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 13:34:22 +0200
commitfa84b40970f43d957a6e3bcd08d45477360cc09a (patch)
treeae345ca4ab7ea5f4ea6c9c50061d2cd13cbeaaa9 /dev-python/pyzotero
parentmedia-gfx/graphviz: Stabilize 11.0.0 amd64, #935533 (diff)
downloadgentoo-fa84b40970f43d957a6e3bcd08d45477360cc09a.tar.gz
gentoo-fa84b40970f43d957a6e3bcd08d45477360cc09a.tar.bz2
gentoo-fa84b40970f43d957a6e3bcd08d45477360cc09a.zip
dev-python/pyzotero: add 1.5.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyzotero')
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.20.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index f1069734c7d1..b228f334b928 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1,2 +1,3 @@
DIST pyzotero-1.5.18.tar.gz 527435 BLAKE2B 27ab1ccf32c260098a684ce4ee05c9acdedec787ec268ebe994d4e9904b9aae73c4a48bb169ec84d727d780c2168e177bcb47209d0f09dc661dd990f1a4075db SHA512 c45e18de0ed479b0ce03cc69ec7a2b060370d6c26e57fa707d2230078e87cdb9eb70f341bac8533a9fa6f4101f29aeca8767befa1e275c0dbd7e778e9c227c21
DIST pyzotero-1.5.19.tar.gz 527472 BLAKE2B 3cd188812f44d4f3d77fb74c7a2e915969f835a941234b60975d11435d651408cb86462ba684a607698ab634138389999796749217be8b4db1bdd8a9b3dffd8c SHA512 ffb466592f96f2af5775d7b57da3dd314809605c57a1fcbe863003eed1774e9bf89d99e3bc549c61fbaf29a0d520c0eaa767ff0dd9cdaae538a6880018b6347e
+DIST pyzotero-1.5.20.tar.gz 526300 BLAKE2B 7f9110d70843563ce675c2efadc2e7f336671e4e6c9b70ead48dfec1680dd48ec3b4f6ea2898ed37e4548bca4cdeb68d4f50e68f617aefcb94002c9fe1881a40 SHA512 925b1c735c05a251d19de64565e83a91a88e6f21ac9ce0a14bb6fe4288337ff3564623589d1bf1b3c3794d25081e72aa21b9582716a2e4391f404107a9d5a62a
diff --git a/dev-python/pyzotero/pyzotero-1.5.20.ebuild b/dev-python/pyzotero/pyzotero-1.5.20.ebuild
new file mode 100644
index 000000000000..07c2b497906d
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="BlueOak-1.0.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ >=dev-python/trove-classifiers-2024.7.2[${PYTHON_USEDEP}]
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest