summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-31 08:02:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-31 09:13:10 +0200
commit7a516028a4428f21912a4f1e9a1701f4043c4d0f (patch)
treeec515ae859cb1f5d8e29256ed9c7de6873e1e992 /dev-python/pyupgrade
parentdev-python/tokenize-rt: Bump to 5.2.0 (diff)
downloadgentoo-7a516028a4428f21912a4f1e9a1701f4043c4d0f.tar.gz
gentoo-7a516028a4428f21912a4f1e9a1701f4043c4d0f.tar.bz2
gentoo-7a516028a4428f21912a4f1e9a1701f4043c4d0f.zip
dev-python/pyupgrade: Bump to 3.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.10.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index 389c9cc92074..0fd7f118e446 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1 +1,2 @@
+DIST pyupgrade-3.10.1.gh.tar.gz 63457 BLAKE2B 54c3105b4e84025e8204b29abeaec813e7959f21bfe1d4d5dfef4caae355885a4be0459685b05eb38266ec4bd14f1736304c404f14c909f51bb554e249f9906c SHA512 47579a1116a56f64dc190956ce708a4a99ae93bdc446a060b2a6418b026ff249d53dc98a5e5153203af2f00f6a1335bc66908e1ae8ead1ad957edf35854cfa8c
DIST pyupgrade-3.9.0.gh.tar.gz 63231 BLAKE2B 5b8bcba1d5f20379a2fe12df3f515222ccf05a67c6666c9de9caddc2f667010eec296f5c64354dbd56170a94f3cba00e0556f34c5f0cc2ffcc4e3a289790d24f SHA512 572f5b30ce18d86ed2e0cae102cc05940e58be325e0dffb4d5c23e7ed377e497d74c01f44d2bf32a18d04eaed282df5007f5f9eea5633fc46f196c63a6fcc134
diff --git a/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild b/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild
new file mode 100644
index 000000000000..19a841ef7eff
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/tokenize-rt-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest