summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 09:36:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 09:36:34 +0200
commitaee01c1b66d4f25b92f5592ba4c91cf20da39a31 (patch)
tree11c933200c09d7f5126af2d523d0a51bd2d40340 /dev-python/python-gnupg
parentdev-python/decorator: Version Bump (diff)
downloadgentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.tar.gz
gentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.tar.bz2
gentoo-aee01c1b66d4f25b92f5592ba4c91cf20da39a31.zip
dev-python/python-gnupg: Version Bump
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-gnupg')
-rw-r--r--dev-python/python-gnupg/Manifest1
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.8.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/Manifest b/dev-python/python-gnupg/Manifest
index 4d6eeaf2d440..daffb933cd69 100644
--- a/dev-python/python-gnupg/Manifest
+++ b/dev-python/python-gnupg/Manifest
@@ -1 +1,2 @@
DIST python-gnupg-0.3.7.tar.gz 48728 SHA256 2bf59ff55c036e49d5da12d370447679f14d242567df4c2c0fc61b4601ca0d59 SHA512 6166cef11307dd4782000ab7263778436998a816a45e4471fcbe244b123703bf9ded5bc6ef5cd47ed0c561ef42660980576edf57c62029bb0326642b7c538dd3 WHIRLPOOL 93770439486689dfcaf296d158c3978a71c72d32ba9f0e5b4ec4c97dfda16177ee5e06f0b616112cdfb9cd96c3a93700a0d4302116401c6146f3cd7437b7e29b
+DIST python-gnupg-0.3.8.tar.gz 38993 SHA256 3872ced77d69203f31817107b324b0dd33d4437a330dc58eca140c8758d26b5a SHA512 128ba1f89e8baf0d1ae53153d7cbe73bfc99617a1aadfd9a02e2e2e2c5f0bb9c7482023bf54f32989e92cc14a9eb32325e4c358c63bce48a70a78d068103ed4f WHIRLPOOL 9080ceeade7e4c614a532eccbd4e9818d62233a6d1751acb159e8e0f13c71edf177d2c1592f0685c7e4139ba59826b8cb13864c11c37e33445a176c693d84f52
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
new file mode 100644
index 000000000000..74e1a0bef119
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}