summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-08-03 23:33:19 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-11 22:44:26 +0200
commitac293f205ae49d36e942eb5b3d5d9ee470cb85e6 (patch)
tree53bd25ae9c2c8f01f82530500febd357201d426c /dev-python/python-gnupg/python-gnupg-0.4.3.ebuild
parentprofiles: Drop obsolete media-libs/libsdl2[fusionsound] p.use.mask (diff)
downloadgentoo-ac293f205ae49d36e942eb5b3d5d9ee470cb85e6.tar.gz
gentoo-ac293f205ae49d36e942eb5b3d5d9ee470cb85e6.tar.bz2
gentoo-ac293f205ae49d36e942eb5b3d5d9ee470cb85e6.zip
dev-python/python-gnupg: bump to version 0.4.3
Bumped to EAPI="7". Added pypy3 and python 3.7 support. Closes: https://bugs.gentoo.org/662750 Closes: https://github.com/gentoo/gentoo/pull/9434 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.4.3.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.4.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.3.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.3.ebuild
new file mode 100644
index 000000000000..f5deea7ec6ed
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( pypy{,3} python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for GnuPG"
+HOMEPAGE="https://bitbucket.org/vinay.sajip/python-gnupg
+ https://pypi.org/project/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-skip_network_needing_test.patch
+ "${FILESDIR}"/${P}-use_seperate_keys_directory.patch
+)
+
+python_test() {
+ "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
+}