summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-02 07:37:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-02 07:37:45 +0200
commit3fc407ebbe2c262b2e0f4f4c8651a6eb5c332992 (patch)
tree286223cd774ecc30a183f96d4e01bbcf0da802f2 /dev-python/python-engineio
parentsys-apps/diffutils: Bump to version 3.8 (diff)
downloadgentoo-3fc407ebbe2c262b2e0f4f4c8651a6eb5c332992.tar.gz
gentoo-3fc407ebbe2c262b2e0f4f4c8651a6eb5c332992.tar.bz2
gentoo-3fc407ebbe2c262b2e0f4f4c8651a6eb5c332992.zip
dev-python/python-engineio: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 4becfffe164c..a831bd520b40 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -2,3 +2,4 @@ DIST python-engineio-3.12.1.tar.gz 37158 BLAKE2B a3f75b0ec197248029a2a257eee7694
DIST python-engineio-4.0.1.gh.tar.gz 296000 BLAKE2B dc3b2c3f25ebbfb9d795e3c08e82b2e001fbc785dfb1666f137d8b261b65a90a15af7527917bdd9c636f076f75e01c65b498145ae5051649e1264eb9339d9f7e SHA512 83886ed1a60465127b7eb42a8437196cd68f4c538076237e4f64ff36f6fb02d1e45bd6730d4bb6209c931e05b4c2e10bae60451d1d4644071178ff44a73805e9
DIST python-engineio-4.1.0.gh.tar.gz 296431 BLAKE2B 5ab267aba4dc6e49d26166b661da5b40961d328efb92dbcb653a405f62956f33b28dbf48cd891d0e74314da998be477f917dd6eabdf154877cd80077e4172c9f SHA512 5dea0ffc24138664216eefd6f917280d6199e4c2661a2e41622bb7f4cf03467d60d555e5c28ba23c35f59ae8b549902d235308242bbc5607ac91fd61580e0c4f
DIST python-engineio-4.2.0.gh.tar.gz 297410 BLAKE2B 140dd21e779fd89f4d94ee3d191f0b661fa9dab2fac86c1023039afbe83d5136206add52ad412148eff69e79c84b7a8ad1744b3b2c69e02a270373c8c4a38488 SHA512 02eaa5b03045ac1ba73dbcd8c7c7853526234afb61dee6de45ee18bdf3663a2f82f9a5c969fb679e3eb8ccfe5a959434d574c59648b23d3e8e876d22f90e0591
+DIST python-engineio-4.2.1.gh.tar.gz 297657 BLAKE2B 0a634cec9f71a3b8659e5b07cc326fb3d7801c8a834248d6f2ea5a48bcd058f8d0b86c2e43c110ea18ef641e3ace273a2ebd20f350aec9360d38ffe0f32f2778 SHA512 f0ea7cb0a34f49d2e3de58dc1038f41cda099fba0033af7020b9ccacd34fbf44fd1613ef14d4d05013dd99a2d35330769e6c3d2f532556fd39262229e40714f6
diff --git a/dev-python/python-engineio/python-engineio-4.2.1.ebuild b/dev-python/python-engineio/python-engineio-4.2.1.ebuild
new file mode 100644
index 000000000000..3fba6ef7d60a
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest