summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 08:46:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 09:31:09 +0200
commitdca0a2384a092fad224950722fb147fc32d329fd (patch)
tree43fdc6e21c6c40844a371285bbe4641a42dab1e1 /dev-python/python-editor
parentdev-python/trimesh: Bump to 3.12.8 (diff)
downloadgentoo-dca0a2384a092fad224950722fb147fc32d329fd.tar.gz
gentoo-dca0a2384a092fad224950722fb147fc32d329fd.tar.bz2
gentoo-dca0a2384a092fad224950722fb147fc32d329fd.zip
dev-python/python-editor: Use PEP517, EAPI 8, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-editor')
-rw-r--r--dev-python/python-editor/python-editor-1.0.4-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-editor/python-editor-1.0.4-r2.ebuild b/dev-python/python-editor/python-editor-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..dc43d461812a
--- /dev/null
+++ b/dev-python/python-editor/python-editor-1.0.4-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result"
+HOMEPAGE="
+ https://github.com/fmoo/python-editor/
+ https://pypi.org/project/python-editor/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"