summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 20:17:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 20:19:10 +0200
commit577d04535cd56925b28ebec89745c576f2cccdf4 (patch)
tree2148c60eb126e9cf3d0e8838ddfe018e445f31e5 /dev-python/python-docs/python-docs-3.7.9.ebuild
parentdev-python/python-docs: Bump to 3.6.12 (diff)
downloadgentoo-577d04535cd56925b28ebec89745c576f2cccdf4.tar.gz
gentoo-577d04535cd56925b28ebec89745c576f2cccdf4.tar.bz2
gentoo-577d04535cd56925b28ebec89745c576f2cccdf4.zip
dev-python/python-docs: Bump to 3.7.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs/python-docs-3.7.9.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.7.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.7.9.ebuild b/dev-python/python-docs/python-docs-3.7.9.ebuild
new file mode 100644
index 000000000000..16f1d2327d67
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}