summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-25 04:59:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-25 04:59:12 +0200
commitc6ec5d1f9be769f07327071ca0ab269ca9cc69d1 (patch)
treebaa65d26ee9bb13bfc665e6f2dc7bbb7ad0e831b /dev-python/pytest-env
parentdev-python/mistletoe: Bump to 1.2.1 (diff)
downloadgentoo-c6ec5d1f9be769f07327071ca0ab269ca9cc69d1.tar.gz
gentoo-c6ec5d1f9be769f07327071ca0ab269ca9cc69d1.tar.bz2
gentoo-c6ec5d1f9be769f07327071ca0ab269ca9cc69d1.zip
dev-python/pytest-env: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/pytest-env-1.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index 2edb2ba86520..eed9731c9169 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1,2 +1,3 @@
DIST pytest_env-0.8.2.tar.gz 7419 BLAKE2B c07140de76392bcf316935efaa52aea344c7167a95fe497c3702dd2aabc3150641f0903f2de6ee1794453dc2e5b1630d746b2fcb3dbcea8edb9ba066cde0a0b4 SHA512 6fbbb6b1db21ebeb47c472e10adb9bacedcdbbabceeaf93b01146ec7e175005aeef46616a4343bf02b23561c0ff5815506fe356f337371dfc057ee29521f68af
DIST pytest_env-1.0.0.tar.gz 7456 BLAKE2B 9eaf71aa05a9a4b8783184dce1f1779b5ee54da54839f1113c9276df7cb4c4ef6055aadad7d20063d4c5c24654f2d100970bdae540eac49b89f049b78be49e93 SHA512 9d25c704e253c11e77933911817ba2b42127c13c38615e1cbf11575cfced81c69a46603bef680ee371512788acb6359a76841019837d55151490fd1f093bb83b
+DIST pytest_env-1.0.1.tar.gz 7565 BLAKE2B 26aa1c6a5d44bbe40266bbb62ca62c687dd1d85aed821c271f301ff27a97fdc753d2cdf5feba8b223b33b5b05bf39c55c3df0f1f8f7aae77335f2052a65df6c0 SHA512 422aaa78e25fad7b447f06358b772cacf22d5441ae0aaac22863877424f44703c1329813b068d901d4f2fb9df21bb08a5e4082504b76102d02dd15087d527a01
diff --git a/dev-python/pytest-env/pytest-env-1.0.1.ebuild b/dev-python/pytest-env/pytest-env-1.0.1.ebuild
new file mode 100644
index 000000000000..f4a8973c08bf
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}