summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 08:45:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 08:45:53 +0200
commitb85a885f00dd20425fc5bec73aea05927b66d193 (patch)
treee41b760f1f13b11146e744ea96c44aa3fda881d7 /dev-python/pytest-asyncio
parentapp-cdr/gcdemu: Bump to 3.2.5 (diff)
downloadgentoo-b85a885f00dd20425fc5bec73aea05927b66d193.tar.gz
gentoo-b85a885f00dd20425fc5bec73aea05927b66d193.tar.bz2
gentoo-b85a885f00dd20425fc5bec73aea05927b66d193.zip
dev-python/pytest-asyncio: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 5e40c6e37330..cc81e265e9ab 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1 +1,2 @@
DIST pytest-asyncio-0.14.0.tar.gz 14796 BLAKE2B 0a110dabde491293dc10452239971809ec6a4006a2036e848aac067df1af328d0d1d5c7afae8cfc1ecf5c919c0922050e2db182065500ec614a8094d3799c0cd SHA512 d1fadff152a0c94f80a8272a0dd293bd9d9300ad9e79c69556b5901c1a8ce00545f7715e503a383e3f4f35c8090d8f9ec33d16739b85378b59b1786a50441fca
+DIST pytest-asyncio-0.15.0.tar.gz 15555 BLAKE2B e9f0b732a1ff81c02cccbeddcebc593ceb982a640c5da2cf644ffc8e57548795cefdb7464bb1bb0d9a7d96a7476d30665dbea1c2b25341f8e71b16512c9402db SHA512 a936bd8f00cb470cee355b9abe6a6df5f65af5de9144bc0c128732f65fe4bc1e60b08a4e7287ae2f303e56e1764fd0bfe771102439e6d1ba7cb495d06b0677c0
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild
new file mode 100644
index 000000000000..bcbcda7b5f7e
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest