summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyspf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/Manifest2
-rw-r--r--dev-python/pyspf/metadata.xml8
-rw-r--r--dev-python/pyspf/pyspf-2.0.10.ebuild35
-rw-r--r--dev-python/pyspf/pyspf-2.0.11.ebuild35
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pyspf/Manifest b/dev-python/pyspf/Manifest
new file mode 100644
index 000000000000..cb15e9a9b28e
--- /dev/null
+++ b/dev-python/pyspf/Manifest
@@ -0,0 +1,2 @@
+DIST pyspf-2.0.10.tar.gz 62890 SHA256 0a3be1cc1915649ed8960a1b8add4110379c3c348e98e642a53f69d028709de8 SHA512 8a10a82fe5226ffee6376ea19f1fe075bb8676cd7eeadbfec1de95326fb8e6f08ad466e84129c016b62452f26f0552f1a463fc6a53d992c67ae1d8b1a18b3a46 WHIRLPOOL 5cceeda27c6a84f827c1505f7808e371f5eecc95737a98cd77d0b06dcccd58fe0d0971b9ecfadc7c23c69ee921eefe56cbb98974c47ea3b57d1b0bcfae5e050f
+DIST pyspf-2.0.11.tar.gz 63594 SHA256 693e80df3d61d69daaa2590e0f2bc8167d5fa36ce373d43987984cb00ae23928 SHA512 cababa82d1b6c206033a6583a67502d982a2c34baec0ccc08513a2bc9beb4cfc84dd5d615ac852fd25885c4abd43d9e8704f517c70fadb4a600d3b8a6254d755 WHIRLPOOL f1f97b8d0c6207a01d5d48aa3f63948749d3ceca590c146ec846638e263ba8155616e9d34af0bdfde3c1438869a3727a98154c054e0e33632c8cccd23d3f2e3d
diff --git a/dev-python/pyspf/metadata.xml b/dev-python/pyspf/metadata.xml
new file mode 100644
index 000000000000..1c6beeda5d8d
--- /dev/null
+++ b/dev-python/pyspf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyspf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyspf/pyspf-2.0.10.ebuild b/dev-python/pyspf/pyspf-2.0.10.ebuild
new file mode 100644
index 000000000000..f001157965dc
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ipv6?"
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="http://pypi.python.org/pypi/pyspf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ipv6 test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}
diff --git a/dev-python/pyspf/pyspf-2.0.11.ebuild b/dev-python/pyspf/pyspf-2.0.11.ebuild
new file mode 100644
index 000000000000..b0a67f4fc847
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ipv6?"
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="http://pypi.python.org/pypi/pyspf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}