summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-18 21:02:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-18 21:07:38 +0300
commit4c79f44fa2b74a6ef4616e21c5f8a1c90b943d3b (patch)
treef8bc15421897c681692ab96cef0e537bfa5cb36e /dev-python/pypiserver
parentdev-python/more-itertools: add 9.0.0 (diff)
downloadgentoo-4c79f44fa2b74a6ef4616e21c5f8a1c90b943d3b.tar.gz
gentoo-4c79f44fa2b74a6ef4616e21c5f8a1c90b943d3b.tar.bz2
gentoo-4c79f44fa2b74a6ef4616e21c5f8a1c90b943d3b.zip
dev-python/pypiserver: add 1.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pypiserver')
-rw-r--r--dev-python/pypiserver/Manifest1
-rw-r--r--dev-python/pypiserver/pypiserver-1.5.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pypiserver/Manifest b/dev-python/pypiserver/Manifest
index f915562aa4ae..6c4aaf7288cc 100644
--- a/dev-python/pypiserver/Manifest
+++ b/dev-python/pypiserver/Manifest
@@ -1 +1,2 @@
DIST pypiserver-1.5.0.gh.tar.gz 149963 BLAKE2B bfc0760982f97e93357702342eb5b1776f72c43e66742a8741ee2ba3109839006e99e49b65e04380097500c400e09bce77b74fc5f9072c7670349817ae3a73cb SHA512 c93e724a3aa6ec265d483c2989129292a05132d3d52db6d9b9c1429610ee23b56e106c9389bdfaad142f34071ee258bdd4291668c11f8bb412df043bf4555611
+DIST pypiserver-1.5.1.gh.tar.gz 150145 BLAKE2B 23ceba3064da4a0d7a19af0a48f370913948dd8cec101cdee43f59c78087b71adcb0fb3a494ca1a94cf3cc2c42751f8710f9cf9037401d73bec7f94f300dbf6b SHA512 35797c37ecfc2c7de21211c5c5f9c0edf98ba49e54fbee779099e411dde73377706aeddcd3dfb34c3ae2ef7d7f4ebf9146c3fb02b0778742d688f8ac17a64cfd
diff --git a/dev-python/pypiserver/pypiserver-1.5.1.ebuild b/dev-python/pypiserver/pypiserver-1.5.1.ebuild
new file mode 100644
index 000000000000..3796c36d2b11
--- /dev/null
+++ b/dev-python/pypiserver/pypiserver-1.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Minimal PyPI server"
+HOMEPAGE="
+ https://github.com/pypiserver/pypiserver/
+ https://pypi.org/project/pypiserver/
+"
+SRC_URI="
+ https://github.com/pypiserver/pypiserver/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.25.0[${PYTHON_USEDEP}]
+"
+# NB: many test deps are optional/specific to tests we skip
+BDEPEND="
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/passlib-1.6[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-unbundle-bottle.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove bundled bottle (sic!)
+ rm pypiserver/bottle.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_server.py::test_hash_algos
+ tests/test_server.py::test_pipInstall_openOk
+ tests/test_server.py::test_pipInstall_authedOk
+ # TODO
+ tests/test_app.py::test_root_count
+ tests/test_server.py::test_pip_install_open_succeeds
+ tests/test_server.py::test_pip_install_authed_succeeds
+ # seems to rely on internal bottle details
+ tests/test_main.py::test_auto_servers
+ )
+
+ if ! has_version dev-python/twine; then
+ EPYTEST_DESELECT+=(
+ tests/test_server.py::test_twine_upload
+ tests/test_server.py::test_twine_register
+ )
+ fi
+
+ epytest tests
+}