summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-07 10:08:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-07 10:10:24 +0100
commita1767837db0c7e66ce8dbe6ab0bbda150f41f0a9 (patch)
tree9f57fda677a4e82cd1e13a360fe5e9f6e24f934f /dev-python/pyparted
parentdev-python/pyparted: Port to py3.9, correct deps (diff)
downloadgentoo-a1767837db0c7e66ce8dbe6ab0bbda150f41f0a9.tar.gz
gentoo-a1767837db0c7e66ce8dbe6ab0bbda150f41f0a9.tar.bz2
gentoo-a1767837db0c7e66ce8dbe6ab0bbda150f41f0a9.zip
dev-python/pyparted: Bump to 3.11.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/Manifest1
-rw-r--r--dev-python/pyparted/pyparted-3.11.7.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index f5fba8b280f5..b362f135d675 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1 +1,2 @@
DIST pyparted-3.11.6.tar.gz 105633 BLAKE2B 8c74fb3521f94cf726365e91954c56a60bc418c0e18c3401dc525f942169b1c03ade5fa35d5053daf4a4568b373e9a8771e50c76ea5b51c2f6351ce62ed2bb21 SHA512 8c3a86efb21c212a8f227ae324896552f45568b8facdd76729f5acf15bf7d691c1b9ab9e46885e4fa4e0c4c7d60314e2abfcbff212e5dc158d27ce716dbd50fa
+DIST pyparted-3.11.7.tar.gz 105671 BLAKE2B ffe7869c7ac85f291314d0381e18ca6a732eca2cee3d31fe31a89b8b1c1c671f97a06a586f235ee67244388ab214a7e51c67951a5c1eb79fb1b448f6a004381c SHA512 147fdc45d47faaee574a7b0268a218eef49be929a147d20adf85cc0302d94e57e98e02072591ca035cad7efe164e7dd87bd1a31504f5cff8575f18d4469dc2b0
diff --git a/dev-python/pyparted/pyparted-3.11.7.ebuild b/dev-python/pyparted/pyparted-3.11.7.ebuild
new file mode 100644
index 000000000000..5535859ce228
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="https://github.com/dcantrell/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=sys-block/parted-3.2
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest