summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2018-08-15 00:25:42 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-15 00:26:09 +0200
commitc4b0e9b97ceec051a6eebee282df1d11a71c68c9 (patch)
tree189cea0a8acfb161c0541aa33a0e4d41eca6e443 /dev-python/pymongo
parentdev-python/pymongo: version bump (diff)
downloadgentoo-c4b0e9b97ceec051a6eebee282df1d11a71c68c9.tar.gz
gentoo-c4b0e9b97ceec051a6eebee282df1d11a71c68c9.tar.bz2
gentoo-c4b0e9b97ceec051a6eebee282df1d11a71c68c9.zip
dev-python/pymongo: drop old
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-2.7.2.ebuild120
-rw-r--r--dev-python/pymongo/pymongo-2.9.3.ebuild133
3 files changed, 0 insertions, 255 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 3549eef3c31e..25d103921eec 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,5 +1,3 @@
-DIST pymongo-2.7.2.tar.gz 381455 BLAKE2B 8b8836f59387d4509312b7ee45f49ca228562a56dee6b7fbadf3074cfe47520691c6e86ed864d597f2bee627c86b79a54458862eb2ea12ad3705811c08b167ae SHA512 0e78495462d670c168e716a7c34e05f6a11a203f0bf9b32c1488608343588a48cbbb76ce715411b310359de19d9cd57c75f80ac7d8195a122a760cec22e8d0c7
-DIST pymongo-2.9.3.tar.gz 433339 BLAKE2B a6caf8dc6fbf1c56ac26ed817257584749797e6cc1b00f9969a5bf48d2b1473e3e3dba45988f8ad0ba909cbbc1069fbdb177c86473c4cbe047cd16844b77be5f SHA512 7b0c46ef1ca27e8c4d99d00c764aa1ce7775503d5210513ca848215fe0be847871c6d62d14f365474606b4abfdb7d1967d3f393e545cdca8929f7fa6a497c32f
DIST pymongo-3.4.0.tar.gz 583303 BLAKE2B 2031b52731db8c5def167b2aceb4e1d064f0ff2391f71d2507cfc03ab932b4e1150d61a7b039b6183f5aa305e5e562110709a858174f37f0523d44d50d7c642c SHA512 c59dcc08803f23134aa4a86605fab0f5c59b829325b632fc1e0149f20018a544b3d65f3c1fda6066248cd258715339b1771ca8d40c38be02c301f5b6421abd1b
DIST pymongo-3.5.1.tar.gz 1332463 BLAKE2B d581409a4b6cdede3e126e31747d34ed0e238919163ed442477ae51765ebdd1ebfb53fc94f7f1f53161c2019bf9db46640730aa54f19af6af25a37c95372308d SHA512 67526bcc27233b85226d7ef6aacce6dfb848efc88730fb8207c3b610f3943ac813f6c2842b7e514d733a65a2b7ea4f255574732e42372551b1b333e3437fd82f
DIST pymongo-3.7.1.tar.gz 723014 BLAKE2B fd0be64f01006405f30e8d96e5edc0d565a8b67ec057a27b6143b4dd0592e2302efea65b6e3d4898d12e196b1efe01787aa608d8564573a83bfd193c703ba0c4 SHA512 34f7448c90a0741d1c80e5924d53e70d5c4bf74d140ea50cef1a519e11b7429dc8551ddb868ec4c02351da6619924ae0d4f7bfc12ef4fa9635c81e2f69aea30f
diff --git a/dev-python/pymongo/pymongo-2.7.2.ebuild b/dev-python/pymongo/pymongo-2.7.2.ebuild
deleted file mode 100644
index ac52bfe54a60..000000000000
--- a/dev-python/pymongo/pymongo-2.7.2.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit check-reqs distutils-r1
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~hppa x86"
-IUSE="doc kerberos test"
-
-RDEPEND="
- kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-db/mongodb-2.6.0
- )
-"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-reqcheck() {
- if use test; then
- # During the tests, database size reaches 1.5G.
- local CHECKREQS_DISK_BUILD=1536M
-
- check-reqs_${1}
- fi
-}
-
-pkg_pretend() {
- reqcheck pkg_pretend
-}
-
-pkg_setup() {
- reqcheck pkg_setup
-}
-
-python_compile_all() {
- if use doc; then
- mkdir html || die
- sphinx-build doc html || die
- fi
-}
-
-python_test() {
- # Yes, we need TCP/IP for that...
- local DB_IP=127.0.0.1
- local DB_PORT=27000
-
- export DB_IP DB_PORT
-
- local dbpath=${TMPDIR}/mongo.db
- local logpath=${TMPDIR}/mongod.log
-
- # Now, the hard part: we need to find a free port for mongod.
- # We're just trying to run it random port numbers and check the log
- # for bind errors. It shall be noted that 'mongod --fork' does not
- # return failure when it fails to bind.
-
- mkdir -p "${dbpath}" || die
- while true; do
- ebegin "Trying to start mongod on port ${DB_PORT}"
-
- LC_ALL=C \
- mongod --dbpath "${dbpath}" --smallfiles --nojournal \
- --bind_ip ${DB_IP} --port ${DB_PORT} \
- --unixSocketPrefix "${TMPDIR}" \
- --logpath "${logpath}" --fork \
- && sleep 2
-
- # Now we need to check if the server actually started...
- if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
- # yay!
- eend 0
- break
- elif grep -q 'Address already in use' "${logpath}"; then
- # ay, someone took our port!
- eend 1
- : $(( DB_PORT += 1 ))
- continue
- else
- eend 1
- eerror "Unable to start mongod for tests. See the server log:"
- eerror " ${logpath}"
- die "Unable to start mongod for tests."
- fi
- done
-
- local failed
- #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
- pushd "${BUILD_DIR}"/../ > /dev/null
- if [[ "${EPYTHON}" == python3* ]]; then
- 2to3 --no-diffs -w test
- fi
- DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
-
- mongod --dbpath "${dbpath}" --shutdown || die
-
- [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
-
- rm -rf "${dbpath}" || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pymongo/pymongo-2.9.3.ebuild b/dev-python/pymongo/pymongo-2.9.3.ebuild
deleted file mode 100644
index d4962b861386..000000000000
--- a/dev-python/pymongo/pymongo-2.9.3.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit check-reqs distutils-r1
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="doc kerberos test"
-
-RDEPEND="
- kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[$(python_gen_usedep 'python2*')] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-db/mongodb-2.6.0
- )
-"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-reqcheck() {
- if use test; then
- # During the tests, database size reaches 1.5G.
- local CHECKREQS_DISK_BUILD=1536M
-
- check-reqs_${1}
- fi
-}
-
-pkg_pretend() {
- reqcheck pkg_pretend
-}
-
-pkg_setup() {
- reqcheck pkg_setup
-}
-
-python_compile_docs() {
- if use doc; then
- python_setup 'python2*'
- mkdir html || die
- sphinx-build doc html || die
- fi
-}
-
-python_install_docs() {
- if use doc; then
- python_setup 'python2*'
- local HTML_DOCS=( html/. )
- einstalldocs
- fi
-}
-
-python_test() {
- # Yes, we need TCP/IP for that...
- local DB_IP=127.0.0.1
- local DB_PORT=27000
-
- export DB_IP DB_PORT
-
- local dbpath=${TMPDIR}/mongo.db
- local logpath=${TMPDIR}/mongod.log
-
- # Now, the hard part: we need to find a free port for mongod.
- # We're just trying to run it random port numbers and check the log
- # for bind errors. It shall be noted that 'mongod --fork' does not
- # return failure when it fails to bind.
-
- mkdir -p "${dbpath}" || die
- while true; do
- ebegin "Trying to start mongod on port ${DB_PORT}"
-
- LC_ALL=C \
- mongod --dbpath "${dbpath}" --smallfiles --nojournal \
- --bind_ip ${DB_IP} --port ${DB_PORT} \
- --unixSocketPrefix "${TMPDIR}" \
- --logpath "${logpath}" --fork \
- && sleep 2
-
- # Now we need to check if the server actually started...
- if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
- # yay!
- eend 0
- break
- elif grep -q 'Address already in use' "${logpath}"; then
- # ay, someone took our port!
- eend 1
- : $(( DB_PORT += 1 ))
- continue
- else
- eend 1
- eerror "Unable to start mongod for tests. See the server log:"
- eerror " ${logpath}"
- die "Unable to start mongod for tests."
- fi
- done
-
- local failed
- #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
- pushd "${BUILD_DIR}"/../ > /dev/null
- if [[ "${EPYTHON}" == python3* ]]; then
- 2to3 --no-diffs -w test
- fi
- DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
-
- mongod --dbpath "${dbpath}" --shutdown || die
-
- [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
-
- rm -rf "${dbpath}" || die
-}
-
-src_compile() {
- distutils-r1_src_compile
- python_compile_docs
-}
-
-src_install() {
- distutils-r1_src_install
- python_install_docs
-}