summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pygeocoder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pygeocoder')
-rw-r--r--dev-python/pygeocoder/Manifest1
-rw-r--r--dev-python/pygeocoder/metadata.xml5
-rw-r--r--dev-python/pygeocoder/pygeocoder-1.2.5.ebuild19
3 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pygeocoder/Manifest b/dev-python/pygeocoder/Manifest
new file mode 100644
index 000000000000..a40118a0bd5c
--- /dev/null
+++ b/dev-python/pygeocoder/Manifest
@@ -0,0 +1 @@
+DIST pygeocoder-1.2.5.tar.gz 8105 SHA256 c1b8353ec8877cedd070d58cb597c4a94b70df00dc0c482d43aa9a21c90bbba0 SHA512 eb395d2f334f5a1de9ed8abb6298d16b49ab7c29cc421daecc816737e89fd7c6f205024a553f2b0d559401df8f26729c042604fbb0ed49f5a763fe833db3745f WHIRLPOOL 8b2cf90af2c035afca455d661fdc330f180c89fc23a865dc6aa0df71d6eb7c7265a21cd97bed0420f457ab77e705ad40c680e1297ab0af4a5349030170e2004f
diff --git a/dev-python/pygeocoder/metadata.xml b/dev-python/pygeocoder/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/pygeocoder/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pygeocoder/pygeocoder-1.2.5.ebuild b/dev-python/pygeocoder/pygeocoder-1.2.5.ebuild
new file mode 100644
index 000000000000..d4c887581bfd
--- /dev/null
+++ b/dev-python/pygeocoder/pygeocoder-1.2.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for Google Geocoding API V3"
+HOMEPAGE="http://code.xster.net/pygeocoder/overview"
+SRC_URI="http://code.xster.net/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/requests-1.0[${PYTHON_USEDEP}]"