summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-21 04:45:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-21 04:45:40 +0200
commit9a31c1f1884e398171b8de1db1fc363645e70d47 (patch)
treedab25b79cde093a015eedbcd5bf2da2f4d38d072 /dev-python/pygame
parentdev-python/rapidfuzz: Remove old (diff)
downloadgentoo-9a31c1f1884e398171b8de1db1fc363645e70d47.tar.gz
gentoo-9a31c1f1884e398171b8de1db1fc363645e70d47.tar.bz2
gentoo-9a31c1f1884e398171b8de1db1fc363645e70d47.zip
dev-python/pygame: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/Manifest1
-rw-r--r--dev-python/pygame/files/pygame-2.5.2-error.patch121
-rw-r--r--dev-python/pygame/files/pygame-2.5.2-gcc-14.patch38
-rw-r--r--dev-python/pygame/files/pygame-2.5.2-numpy-2.patch135
-rw-r--r--dev-python/pygame/pygame-2.5.2-r2.ebuild103
-rw-r--r--dev-python/pygame/pygame-2.5.2-r3.ebuild107
6 files changed, 0 insertions, 505 deletions
diff --git a/dev-python/pygame/Manifest b/dev-python/pygame/Manifest
index 4a5df64234de..9d7b5373a2c8 100644
--- a/dev-python/pygame/Manifest
+++ b/dev-python/pygame/Manifest
@@ -1,2 +1 @@
-DIST pygame-2.5.2.gh.tar.gz 5970857 BLAKE2B 523874926a8fd868f5674ed2997a44decb928fcfe246d551249ed7320a0e908ce46d00f459d187726edf74a4c1038cd56821f6466559fb7d24aa75d16769cbfe SHA512 b54e9b80951c8a9e75666621aafc26874c6dbdab27330146f7217346c76be5627a5464a0102a5968eca0dbd7cced4b2143cd2ff1b6227e3e17e5634854b27f19
DIST pygame-2.6.0.gh.tar.gz 5970025 BLAKE2B 2a7616982675d8d9a5f306bae709e97e87d4f602f12ea553ca4779f858fb88bf92ac2a4e0f8f63ac52096e1829d2f7805edee919d7e96b7764db72e9cb7f4034 SHA512 bdf36314bd2179ab30942efab4e4cb65eff023b6951d1705a46d7cb4b89095e76bf4dcd04e714224355705d3e44283213fbb807973b3b241bf128b78c80044ae
diff --git a/dev-python/pygame/files/pygame-2.5.2-error.patch b/dev-python/pygame/files/pygame-2.5.2-error.patch
deleted file mode 100644
index 9f2800e29e70..000000000000
--- a/dev-python/pygame/files/pygame-2.5.2-error.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From bbed8d293483fa7bd7322f5976641dfe86bf6367 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Sat, 7 Oct 2023 12:05:45 +0200
-Subject: [PATCH 1/2] base: Clean up some error messaging
-
----
- src_c/base.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src_c/base.c b/src_c/base.c
-index 1f12a63451..d32c17bdc5 100644
---- a/src_c/base.c
-+++ b/src_c/base.c
-@@ -309,11 +309,13 @@ pg_mod_autoquit(const char *modname)
-
- funcobj = PyObject_GetAttrString(module, "_internal_mod_quit");
-
-+ if (PyErr_Occurred())
-+ PyErr_Clear();
-+
- /* If we could not load _internal_mod_quit, load quit function */
- if (!funcobj)
- funcobj = PyObject_GetAttrString(module, "quit");
-
-- /* Silence errors */
- if (PyErr_Occurred())
- PyErr_Clear();
-
-@@ -322,7 +324,6 @@ pg_mod_autoquit(const char *modname)
- Py_XDECREF(temp);
- }
-
-- /* Silence errors */
- if (PyErr_Occurred())
- PyErr_Clear();
-
-
-From d8fae59ff0f3a02fe159cc302c891177af97a41f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Sat, 7 Oct 2023 12:05:58 +0200
-Subject: [PATCH 2/2] pixelcopy: Clean up some error messaging
-
----
- src_c/pixelcopy.c | 27 +++++++++++++++++++++++++++
- 1 file changed, 27 insertions(+)
-
-diff --git a/src_c/pixelcopy.c b/src_c/pixelcopy.c
-index 923072dde8..1d1eaf3267 100644
---- a/src_c/pixelcopy.c
-+++ b/src_c/pixelcopy.c
-@@ -767,6 +767,9 @@ surface_to_array(PyObject *self, PyObject *args, PyObject *kwds)
- Uint8 opaque = 255;
- Uint8 clear = 0;
- SDL_Surface *surf;
-+ PyObject *type = NULL;
-+ PyObject *value = NULL;
-+ PyObject *traceback = NULL;
- char *keywords[] = {"array", "surface", "kind", "opaque", "clear", 0};
-
- if (!PyArg_ParseTupleAndKeywords(
-@@ -794,8 +797,16 @@ surface_to_array(PyObject *self, PyObject *args, PyObject *kwds)
- if (view_p->ndim == 2) {
- if (view_kind == VIEWKIND_RGB) {
- if (_copy_mapped(view_p, surf)) {
-+ if (PyErr_Occurred()) {
-+ PyErr_Fetch(&type, &value, &traceback);
-+ PyErr_Clear();
-+ }
-+
- pgBuffer_Release(&pg_view);
- pgSurface_Unlock(surfobj);
-+ if (type) {
-+ PyErr_Restore(type, value, traceback);
-+ }
- return 0;
- }
- }
-@@ -876,6 +887,8 @@ map_array(PyObject *self, PyObject *args)
- _pc_pixel_t pixel = {0};
- int pix_bytesize;
- Py_ssize_t i;
-+ PyObject *type = NULL;
-+ PyObject *value, *traceback;
-
- if (!PyArg_ParseTuple(args, "OOO!", &tar_array, &src_array,
- &pgSurface_Type, &format_surf)) {
-@@ -889,6 +902,11 @@ map_array(PyObject *self, PyObject *args)
- /* Determine array shapes and check validity
- */
- if (pgObject_GetBuffer(tar_array, &tar_pg_view, PyBUF_RECORDS)) {
-+ if (PyErr_Occurred()) {
-+ PyErr_Fetch(&type, &value, &traceback);
-+ PyErr_Clear();
-+ }
-+
- goto fail;
- }
- is_tar_alloc = 1;
-@@ -912,6 +930,10 @@ map_array(PyObject *self, PyObject *args)
- goto fail;
- }
- if (pgObject_GetBuffer(src_array, &src_pg_view, PyBUF_RECORDS_RO)) {
-+ if (PyErr_Occurred()) {
-+ PyErr_Fetch(&type, &value, &traceback);
-+ PyErr_Clear();
-+ }
- goto fail;
- }
- is_src_alloc = 1;
-@@ -1134,6 +1156,11 @@ map_array(PyObject *self, PyObject *args)
- pgBuffer_Release(&tar_pg_view);
- }
- pgSurface_Unlock(format_surf);
-+
-+ if (type != NULL) {
-+ PyErr_Restore(type, value, traceback);
-+ }
-+
- return 0;
- }
-
diff --git a/dev-python/pygame/files/pygame-2.5.2-gcc-14.patch b/dev-python/pygame/files/pygame-2.5.2-gcc-14.patch
deleted file mode 100644
index 0d74303bbba4..000000000000
--- a/dev-python/pygame/files/pygame-2.5.2-gcc-14.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 504a11fd4855e33ecb945af1270311aa463aae59 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Sun, 19 May 2024 11:12:33 +0200
-Subject: [PATCH] pypm: Fix incorrect param in Pm_OpenInput
-
----
- src_c/cython/pygame/pypm.pyx | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/src_c/cython/pygame/pypm.pyx b/src_c/cython/pygame/pypm.pyx
-index f2c16c9e2b..54a88fd83a 100644
---- a/src_c/cython/pygame/pypm.pyx
-+++ b/src_c/cython/pygame/pypm.pyx
-@@ -106,7 +106,7 @@ cdef extern from "portmidi.h":
- PmDeviceID inputDevice,
- void *inputDriverInfo,
- long bufferSize,
-- long (*PmPtr) (), # long = PtTimestamp
-+ PmTimeProcPtr time_proc, # long = PtTimestamp
- void *time_info)
-
- PmError Pm_OpenOutput(PortMidiStream** stream,
-@@ -538,11 +538,14 @@ cdef class Input:
- """Instantiate MIDI input stream object."""
-
- cdef PmError err
-+ cdef PmTimeProcPtr PmPtr
- self.device = input_device
- self.debug = 0
-
-+ PmPtr = <PmTimeProcPtr>&Pt_Time
-+
- err = Pm_OpenInput(&(self.midi), input_device, NULL, buffersize,
-- &Pt_Time, NULL)
-+ PmPtr, NULL)
- if err < 0:
- raise Exception(Pm_GetErrorText(err))
-
diff --git a/dev-python/pygame/files/pygame-2.5.2-numpy-2.patch b/dev-python/pygame/files/pygame-2.5.2-numpy-2.patch
deleted file mode 100644
index 37b702e57280..000000000000
--- a/dev-python/pygame/files/pygame-2.5.2-numpy-2.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-From 21859cd1b108c2073dfd5fd197714c2b391e3824 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Tue, 21 May 2024 10:24:52 +0200
-Subject: [PATCH 1/3] test: Fix numpy.alltrue imports to import all instead
- thanks @mgorny
-
----
- test/pixelcopy_test.py | 2 +-
- test/sndarray_test.py | 2 +-
- test/surfarray_test.py | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/test/pixelcopy_test.py b/test/pixelcopy_test.py
-index 6510fd99..46051cd4 100644
---- a/test/pixelcopy_test.py
-+++ b/test/pixelcopy_test.py
-@@ -534,7 +534,7 @@ class PixelCopyTestWithArrayNumpy(unittest.TestCase):
-
- def test_map_array(self):
- try:
-- from numpy import array, zeros, uint8, int32, alltrue
-+ from numpy import array, zeros, uint8, int32, all as alltrue
- except ImportError:
- return
-
-diff --git a/test/sndarray_test.py b/test/sndarray_test.py
-index 5b624caf..7a7a51f3 100644
---- a/test/sndarray_test.py
-+++ b/test/sndarray_test.py
-@@ -1,6 +1,6 @@
- import unittest
-
--from numpy import int8, int16, uint8, uint16, float32, array, alltrue
-+from numpy import int8, int16, uint8, uint16, float32, array, all as alltrue
-
- import pygame
- import pygame.sndarray
-diff --git a/test/surfarray_test.py b/test/surfarray_test.py
-index 0863da77..a9d53fc4 100644
---- a/test/surfarray_test.py
-+++ b/test/surfarray_test.py
-@@ -9,7 +9,7 @@ from numpy import (
- zeros,
- float32,
- float64,
-- alltrue,
-+ all as alltrue,
- rint,
- arange,
- )
---
-2.45.2
-
-From 4a2ede7b8a1e90c77ab90aadd9c26a2757124923 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Sun, 2 Jun 2024 13:15:26 +0200
-Subject: [PATCH 2/3] sndarray_test: Fix some overflowed data sizes
-
----
- test/sndarray_test.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/test/sndarray_test.py b/test/sndarray_test.py
-index 7a7a51f3..57eb71c3 100644
---- a/test/sndarray_test.py
-+++ b/test/sndarray_test.py
-@@ -41,7 +41,7 @@ class SndarrayTest(unittest.TestCase):
- 16, 2, [[0, 0xFFFF], [0xFFFF, 0], [0x00FF, 0xFF00], [0x0F0F, 0xF0F0]]
- )
- check_array(-8, 1, [0, -0x80, 0x7F, 0x64])
-- check_array(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [0xFF, 0]])
-+ check_array(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [-1, 0]])
- check_array(-16, 1, [0, 0x7FFF, -0x7FFF, -1])
- check_array(-16, 2, [[0, -0x7FFF], [-0x7FFF, 0], [0x7FFF, 0], [0, 0x7FFF]])
-
-@@ -78,13 +78,13 @@ class SndarrayTest(unittest.TestCase):
- pygame.mixer.quit()
-
- check_sound(8, 1, [0, 0x0F, 0xF0, 0xFF])
-- check_sound(8, 2, [[0, 0x80], [0x2D, 0x41], [0x64, 0xA1], [0xFF, 0x40]])
-+ check_sound(8, 2, [[0, 0x80], [0x2D, 0x41], [0x64, 0xA1], [125, 0x40]])
- check_sound(16, 1, [0, 0x00FF, 0xFF00, 0xFFFF])
- check_sound(
- 16, 2, [[0, 0xFFFF], [0xFFFF, 0], [0x00FF, 0xFF00], [0x0F0F, 0xF0F0]]
- )
- check_sound(-8, 1, [0, -0x80, 0x7F, 0x64])
-- check_sound(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [0xFF, 0]])
-+ check_sound(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [-1, 0]])
- check_sound(-16, 1, [0, 0x7FFF, -0x7FFF, -1])
- check_sound(-16, 2, [[0, -0x7FFF], [-0x7FFF, 0], [0x7FFF, 0], [0, 0x7FFF]])
- check_sound(32, 2, [[0.0, -1.0], [-1.0, 0], [1.0, 0], [0, 1.0]])
-@@ -123,7 +123,7 @@ class SndarrayTest(unittest.TestCase):
- 16, 2, [[0, 0xFFFF], [0xFFFF, 0], [0x00FF, 0xFF00], [0x0F0F, 0xF0F0]]
- )
- check_sample(-8, 1, [0, -0x80, 0x7F, 0x64])
-- check_sample(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [0xFF, 0]])
-+ check_sample(-8, 2, [[0, -0x80], [-0x64, 0x64], [0x25, -0x50], [-1, 0]])
- check_sample(-16, 1, [0, 0x7FFF, -0x7FFF, -1])
- check_sample(-16, 2, [[0, -0x7FFF], [-0x7FFF, 0], [0x7FFF, 0], [0, 0x7FFF]])
- check_sample(32, 2, [[0.0, -1.0], [-1.0, 0], [1.0, 0], [0, 1.0]])
---
-2.45.2
-
-From 184f8b78e6952aa619e961553835c442b3db8d5c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ren=C3=A9=20Dudfield?= <renesd@gmail.com>
-Date: Sun, 2 Jun 2024 13:27:34 +0200
-Subject: [PATCH 3/3] surfarray_test: Fix for value out of uint32 range
-
-Was in signed 32bit range.
----
- test/surfarray_test.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/test/surfarray_test.py b/test/surfarray_test.py
-index a9d53fc4..ee74290e 100644
---- a/test/surfarray_test.py
-+++ b/test/surfarray_test.py
-@@ -113,10 +113,10 @@ class SurfarrayModuleTest(unittest.TestCase):
-
- def _fill_array2d(self, arr, surf):
- palette = self.test_palette
-- arr[:5, :6] = surf.map_rgb(palette[1])
-- arr[5:, :6] = surf.map_rgb(palette[2])
-- arr[:5, 6:] = surf.map_rgb(palette[3])
-- arr[5:, 6:] = surf.map_rgb(palette[4])
-+ arr[:5, :6] = surf.map_rgb(palette[1]) & 0xFFFFFFFF
-+ arr[5:, :6] = surf.map_rgb(palette[2]) & 0xFFFFFFFF
-+ arr[:5, 6:] = surf.map_rgb(palette[3]) & 0xFFFFFFFF
-+ arr[5:, 6:] = surf.map_rgb(palette[4]) & 0xFFFFFFFF
-
- def _fill_array3d(self, arr):
- palette = self.test_palette
---
-2.45.2
-
diff --git a/dev-python/pygame/pygame-2.5.2-r2.ebuild b/dev-python/pygame/pygame-2.5.2-r2.ebuild
deleted file mode 100644
index 8229c9fa5e6d..000000000000
--- a/dev-python/pygame/pygame-2.5.2-r2.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="
- https://www.pygame.org/
- https://github.com/pygame/pygame/
- https://pypi.org/project/pygame/
-"
-SRC_URI="
- https://github.com/pygame/pygame/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv x86"
-IUSE="examples opengl test X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- <dev-python/numpy-2[${PYTHON_USEDEP}]
- media-libs/freetype
- media-libs/libjpeg-turbo:=
- media-libs/libpng:=
- media-libs/portmidi
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- X? ( media-libs/libsdl2[opengl?,threads(+),video,X] )
- !X? ( media-libs/libsdl2[threads(+)] )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- media-libs/sdl2-mixer[mp3,vorbis,wav]
- )
-"
-# fontconfig used for fc-list
-RDEPEND+="
- media-libs/fontconfig
-"
-# util-linux provides script
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- media-libs/fontconfig
- sys-apps/util-linux
- )
-"
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/pygame/pygame/pull/4035
- "${FILESDIR}/${P}-error.patch"
- # https://github.com/pygame/pygame/pull/4236
- "${FILESDIR}/${P}-gcc-14.patch"
- )
-
- # some numpy-related crash (not a regression)
- # https://github.com/pygame/pygame/issues/4049
- sed -e 's:import numpy:raise ImportError(""):' \
- -i test/pixelcopy_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_configure() {
- PORTMIDI_INC_PORTTIME=1 LOCALBASE="${EPREFIX}/usr" \
- "${EPYTHON}" "${S}"/buildconfig/config.py || die
-}
-
-python_configure_all() {
- find src_c/cython -name '*.pyx' -exec touch {} + || die
- "${EPYTHON}" setup.py cython_only || die
-}
-
-python_test() {
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=disk
- script -eqc "${EPYTHON} -m pygame.tests -v" || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # https://bugs.gentoo.org/497720
- rm -fr "${D}$(python_get_sitedir)"/pygame/{docs,examples} || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}
diff --git a/dev-python/pygame/pygame-2.5.2-r3.ebuild b/dev-python/pygame/pygame-2.5.2-r3.ebuild
deleted file mode 100644
index 4c0e66baff50..000000000000
--- a/dev-python/pygame/pygame-2.5.2-r3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="
- https://www.pygame.org/
- https://github.com/pygame/pygame/
- https://pypi.org/project/pygame/
-"
-SRC_URI="
- https://github.com/pygame/pygame/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv x86"
-IUSE="examples opengl test X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/freetype
- media-libs/libjpeg-turbo:=
- media-libs/libpng:=
- media-libs/portmidi
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- X? ( media-libs/libsdl2[opengl?,threads(+),video,X] )
- !X? ( media-libs/libsdl2[threads(+)] )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- media-libs/sdl2-mixer[mp3,vorbis,wav]
- )
-"
-# fontconfig used for fc-list
-RDEPEND+="
- media-libs/fontconfig
-"
-# util-linux provides script
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- media-libs/fontconfig
- sys-apps/util-linux
- )
-"
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/pygame/pygame/pull/4035
- "${FILESDIR}/${P}-error.patch"
- # https://github.com/pygame/pygame/pull/4236
- "${FILESDIR}/${P}-gcc-14.patch"
- # https://github.com/pygame/pygame/pull/4240
- # https://github.com/pygame/pygame/pull/4254
- # https://github.com/pygame/pygame/pull/4255
- "${FILESDIR}/${P}-numpy-2.patch"
- )
-
- # some numpy-related crash (not a regression)
- # https://github.com/pygame/pygame/issues/4049
- sed -e 's:import numpy:raise ImportError(""):' \
- -i test/pixelcopy_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_configure() {
- PORTMIDI_INC_PORTTIME=1 LOCALBASE="${EPREFIX}/usr" \
- "${EPYTHON}" "${S}"/buildconfig/config.py || die
-}
-
-python_configure_all() {
- find src_c/cython -name '*.pyx' -exec touch {} + || die
- "${EPYTHON}" setup.py cython_only || die
-}
-
-python_test() {
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=disk
- script -eqc "${EPYTHON} -m pygame.tests -v" || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # https://bugs.gentoo.org/497720
- rm -fr "${D}$(python_get_sitedir)"/pygame/{docs,examples} || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}