summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 10:33:48 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 10:34:47 +0200
commit2fefbb589e4a2e107665e0bf40cb2f154c6b8ce6 (patch)
tree68bf1e2e58daf28d859c283441e7d9a02c411cb9 /dev-python/pyface/pyface-4.5.2.ebuild
parentdev-python/traitsui: Version Bump (diff)
downloadgentoo-2fefbb589e4a2e107665e0bf40cb2f154c6b8ce6.tar.gz
gentoo-2fefbb589e4a2e107665e0bf40cb2f154c6b8ce6.tar.bz2
gentoo-2fefbb589e4a2e107665e0bf40cb2f154c6b8ce6.zip
dev-python/pyface: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyface/pyface-4.5.2.ebuild')
-rw-r--r--dev-python/pyface/pyface-4.5.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyface/pyface-4.5.2.ebuild b/dev-python/pyface/pyface-4.5.2.ebuild
new file mode 100644
index 000000000000..0f21cf8c042c
--- /dev/null
+++ b/dev-python/pyface/pyface-4.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests" virtualmake -v -I 'composite_grid_model_test_case*' \
+ -I 'simple_grid_model_test_case*' \
+ -I 'test_split_editor_area_pane*'
+}
+
+python_install_all() {
+ use exmaples && EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}