summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyelemental
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyelemental')
-rw-r--r--dev-python/pyelemental/Manifest1
-rw-r--r--dev-python/pyelemental/files/pyelemental-1.2.0-gcc-4.7.patch25
-rw-r--r--dev-python/pyelemental/metadata.xml9
-rw-r--r--dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild28
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyelemental/Manifest b/dev-python/pyelemental/Manifest
new file mode 100644
index 000000000000..49c663e8c18d
--- /dev/null
+++ b/dev-python/pyelemental/Manifest
@@ -0,0 +1 @@
+DIST pyelemental-1.2.0.tar.bz2 34610 SHA256 83420f754b6700eb585b08a05510e616058a8b0c62ffd1f9dab3eae1df463bc7 SHA512 2053042ed19e73d9fefd1d86d29d6d3f9fbed1b0733273197bf62f908154d96ac4c6f3ca0c314e66fa291ab253e8afcdf514e4fbf3e4ea66741349f45a27b23e WHIRLPOOL cb44b87411c75cb1a1ec09932b1a5c15336063bfac6e430bf6be0415ff820636847b39bfdfffad7c3a1d1017a035895237f556b07ea99b18f0ae228a9ba254e2
diff --git a/dev-python/pyelemental/files/pyelemental-1.2.0-gcc-4.7.patch b/dev-python/pyelemental/files/pyelemental-1.2.0-gcc-4.7.patch
new file mode 100644
index 000000000000..a0a53a67be28
--- /dev/null
+++ b/dev-python/pyelemental/files/pyelemental-1.2.0-gcc-4.7.patch
@@ -0,0 +1,25 @@
+ value-types.tcc | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/value-types.tcc b/value-types.tcc
+index 5afc8d0..a95ccbf 100644
+--- a/value-types.tcc
++++ b/value-types.tcc
+@@ -44,7 +44,7 @@ ValueType_t (bool)::ready (PyObject* module)
+
+ ValueType_t (PyObject*)::wrap (const cxxtype& source)
+ {
+- return wrap_copy (&type, source);
++ return ValueType::wrap_copy (&type, source);
+ }
+
+
+@@ -160,7 +160,7 @@ ValueListType_t (bool)::ready (PyObject* module)
+
+ ValueListType_t (PyObject*)::wrap (const cxxtype& source)
+ {
+- return wrap_copy (&type, source);
++ return ValueListType::wrap_copy (&type, source);
+ }
+
+
diff --git a/dev-python/pyelemental/metadata.xml b/dev-python/pyelemental/metadata.xml
new file mode 100644
index 000000000000..b6b1bfeaddfb
--- /dev/null
+++ b/dev-python/pyelemental/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="freecode">gelemental</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild b/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..a815361614a4
--- /dev/null
+++ b/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libelemental (sci-chemistry/gelemental)"
+HOMEPAGE="http://freecode.com/projects/gelemental/"
+SRC_URI="http://www.kdau.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=sci-chemistry/gelemental-1.2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/html/. )
+ distutils-r1_python_install_all
+}