summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-19 20:52:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-19 21:28:07 +0300
commit13dcd147145db9d5f6630951498d52a1b8e22abd (patch)
tree2e77b78f904db10be0212a054a5fbb2b99cacc19 /dev-python/pydyf
parentdev-python/fastjsonschema: add 2.16.2 (diff)
downloadgentoo-13dcd147145db9d5f6630951498d52a1b8e22abd.tar.gz
gentoo-13dcd147145db9d5f6630951498d52a1b8e22abd.tar.bz2
gentoo-13dcd147145db9d5f6630951498d52a1b8e22abd.zip
dev-python/pydyf: add 0.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pydyf')
-rw-r--r--dev-python/pydyf/Manifest1
-rw-r--r--dev-python/pydyf/pydyf-0.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydyf/Manifest b/dev-python/pydyf/Manifest
index 67f47ca9d682..047dd8aa4298 100644
--- a/dev-python/pydyf/Manifest
+++ b/dev-python/pydyf/Manifest
@@ -1 +1,2 @@
DIST pydyf-0.2.0.gh.tar.gz 14530 BLAKE2B 00c696ea191abe111bf0ef098507f34ebaaaee516dc1afc46a194f3e051171ad1854292f5a3fcf1b559945990647ef8cbb308b3afe0dbc05120f15aa74dc8a63 SHA512 276083d8082c5ccc945144b7d2e3ba29f160d5159aa8d27726079dcc09a44a95d5b0f790874425cb41a00b1c22890b435b756b0bbe14ab43e9ad04a8ae2dad0e
+DIST pydyf-0.3.0.gh.tar.gz 14773 BLAKE2B a0d695f73741261e031152bdcfa834b153bc70230996314c5da9234ed388af80d4e2fb24a59a9dabd2e6bbc137696c485ca2a6813361e12d8c74d5a6cc93f60e SHA512 eb4441b0165ab877107ccec41320fdf8b70aebfc9dd1732b6d9fca24d90ba8cb6ac62ce8a90e3b8480ea784e945e240ca00b17648b2b9e17548411f1130b0946
diff --git a/dev-python/pydyf/pydyf-0.3.0.ebuild b/dev-python/pydyf/pydyf-0.3.0.ebuild
new file mode 100644
index 000000000000..a010a449bc5f
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+SRC_URI="
+ https://github.com/CourtBouillon/pydyf/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}