summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 09:49:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 10:04:57 +0100
commite85d38806ee31ad3636907ab1517e75ee1063fd8 (patch)
tree9af1209e0ee29d6c1c9304672c0e27266416b0d6 /dev-python/proto-plus
parentdev-python/proto-plus: Remove old (diff)
downloadgentoo-e85d38806ee31ad3636907ab1517e75ee1063fd8.tar.gz
gentoo-e85d38806ee31ad3636907ab1517e75ee1063fd8.tar.bz2
gentoo-e85d38806ee31ad3636907ab1517e75ee1063fd8.zip
dev-python/proto-plus: Bump to 1.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.20.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 522ce05ae2fa..e16e8c857cf5 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-1.20.0.gh.tar.gz 65648 BLAKE2B 19cfcfde913896de83d17c36bacd7799a9f28ea20c4681266b2194c6521aef116f6a594df8be8912bdf55558d84a0ab09d283ec444ba114592ebb7017db257fe SHA512 1e399bc0ac686f33242c1d15c15255ec1815e94eaf87de03e5145cc6ed249048c3b8af081b70964cb7b6baf8286f6be2f461c3638331a2269a5b2d89976ffa6a
+DIST proto-plus-1.20.1.gh.tar.gz 66180 BLAKE2B ee0299c8e9c9882ce417f6f885df18cd833dfbad80e0e92ca4e589eea794b0b00577d4c01fa69790f97f31d8bdfd20f07f4c7601bdf6ee28a7427f0e56714eb4 SHA512 12d9f76230d592c68083421bbb40c4b57741545c238227a743c275820a4d7ae53ea45d7ae5e73495b14736a95aa96250e243220f8b9bb5c988c12a2f84f654d6
diff --git a/dev-python/proto-plus/proto-plus-1.20.1.ebuild b/dev-python/proto-plus/proto-plus-1.20.1.ebuild
new file mode 100644
index 000000000000..dc2848b431d0
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.20.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme