summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 09:37:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 10:42:18 +0100
commit33d6750192f8b720151763060dfdac33d9b0a950 (patch)
treecf19b0c061c02935599989e783e7608fc06902cd /dev-python/proto-plus
parentdev-python/werkzeug: Bump to 2.0.3 (diff)
downloadgentoo-33d6750192f8b720151763060dfdac33d9b0a950.tar.gz
gentoo-33d6750192f8b720151763060dfdac33d9b0a950.tar.bz2
gentoo-33d6750192f8b720151763060dfdac33d9b0a950.zip
dev-python/proto-plus: Bump to 1.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.20.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 01fdad8c9c9c..49d7eb3da03d 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -2,3 +2,4 @@ DIST proto-plus-1.19.2.gh.tar.gz 61183 BLAKE2B 8c1c0a70ae573fc8c64004e4bd923f403
DIST proto-plus-1.19.7.gh.tar.gz 64614 BLAKE2B 918bb04a084cff8a2188a68c31f08aebd25443fd399d69ba9734d002f773df2769904e4aa551cd1d93586ee4710f2b7160e6a8eb4160fe1bb846be18155a7b29 SHA512 118187a852a998deba3b5d7e700cd084eab966b549c7dba6150f318e9602f950a9533e27d775f9f0bca2fedaed6375b592bae42c55cf5aee8b52708fcc4691c8
DIST proto-plus-1.19.8.gh.tar.gz 64668 BLAKE2B d90ba4bd2404a0b05325e08e9ec39de0b819af00e9229ca54a7173364a99e0cedb584696093f3df7720d96f8291fad4f26b9963171de8ebd44396550dc932e17 SHA512 e9bd790ec7d2cc7fa54e5c8be374e4a7bc5c92899c5259e6985024fe1c9e25768c1355b808a9a4c38b132026412b2e7d91c5fe0098af661b1dac604b84aaf2ee
DIST proto-plus-1.19.9.gh.tar.gz 64845 BLAKE2B 82f6021b912140c49e8625c51050a384f8375a3619a78537f6aadded03ce7524687e8f118cd4081c9a8376b3756c608ed781cac9808fb2c8d0bad9e32d2063ec SHA512 671dad31faf33a81bc90d98ffac599b51930f1f4f17c10c9a1dd5f242b3c55d04b9e59080197cdd42c1c430a72e1e812aadafbcf20cfb5da2fcd17c20e5a69e3
+DIST proto-plus-1.20.0.gh.tar.gz 65648 BLAKE2B 19cfcfde913896de83d17c36bacd7799a9f28ea20c4681266b2194c6521aef116f6a594df8be8912bdf55558d84a0ab09d283ec444ba114592ebb7017db257fe SHA512 1e399bc0ac686f33242c1d15c15255ec1815e94eaf87de03e5145cc6ed249048c3b8af081b70964cb7b6baf8286f6be2f461c3638331a2269a5b2d89976ffa6a
diff --git a/dev-python/proto-plus/proto-plus-1.20.0.ebuild b/dev-python/proto-plus/proto-plus-1.20.0.ebuild
new file mode 100644
index 000000000000..228d58940454
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.20.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ # https://github.com/pytest-dev/pytest/issues/9637#issuecomment-1031997415
+ sed -i -e '/staticmethod/d' tests/test_datetime_helpers.py || die
+ distutils-r1_src_prepare
+}