summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-05 06:40:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-05 06:50:57 +0200
commit76c7c6c5e1f19b727521a9347930936869035567 (patch)
treeaa96eaa850e87853d302103500105cf3031f96fa /dev-python/prompt-toolkit
parentdev-python/google-api-python-client: Bump to 2.132.0 (diff)
downloadgentoo-76c7c6c5e1f19b727521a9347930936869035567.tar.gz
gentoo-76c7c6c5e1f19b727521a9347930936869035567.tar.bz2
gentoo-76c7c6c5e1f19b727521a9347930936869035567.zip
dev-python/prompt-toolkit: Bump to 3.0.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest1
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.46.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index 452d35b5a739..e3a040e312bd 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1,3 +1,4 @@
DIST prompt_toolkit-3.0.43.tar.gz 425733 BLAKE2B 663b3f675e004de9f2d6dce09320bc0bbd6a47f5a581d5b49bb5fe36f0d3eee2022522eac09dccc5bceaf6227e17abe475f133c53b912b3b84f940877aaa6b9a SHA512 833666da9bc7259eec2ee357cb936001880ac1f88c33a1e346ef5e4b8c3fcd37ff7d7102e590d509b0b0ac1e046fcd9d2a7046857c9e95dc3890f1b70c62544c
DIST prompt_toolkit-3.0.44.tar.gz 425654 BLAKE2B 48d080ad6cab2ed192284ae376c65b43a500b7c642b9298af6afc109a16ddf53d8242748af772dd556a568356ab4af95bb71dfb36ec345ee9d4904f0de15fa20 SHA512 09202d023e52eae2200e23be1ed9bfa91ce072c1c6970d00d92fe9f0fabfaa4117b9e174b43b9ae041f4e0605c77a990625e51e51925d1ff63a65a10e09734a8
DIST prompt_toolkit-3.0.45.tar.gz 425324 BLAKE2B 771b1c4b80475f52547d725bbcc5e12223ab15cce9ca5a63c4364615c3f1c6ab23c9e14023178bf2e30467138f1b8407132eb22208fdc29c3c34992c6899c016 SHA512 6e8758e06fac7462821bd803a99f961017cd4e889eb39744fc1a3665983c12fced7bdf0538d83d709040cfb182e3694c1dc31e0c9e62aa08c4b1a7336955d35e
+DIST prompt_toolkit-3.0.46.tar.gz 425591 BLAKE2B 74d10e5bb93cbdf9625f621ca80f15bb012c2839956fa0edaecab7f7af4ce1209eea4eb8fcd403563be5da514f3d08f550d605d44ec2e3b7af136950a9f9428c SHA512 c75dc84a45c24ddbf6074c65aa5e5e0e4ba6d2f1c1a9211e771a534118571b1ad31db57457304365d08091fdf5ad0f8827893269d3963fc1f29b0dd56a12ca64
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.46.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.46.ebuild
new file mode 100644
index 000000000000..4efb2ede21df
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.46.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires tree-sitter-languages
+ src/prompt_toolkit/lexers/tree_sitter_test.py
+)