summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-10-18 13:30:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-10-26 07:53:08 -0400
commit6f5d9fad0e665544f0a10fcf86c9565cbb399485 (patch)
tree8e6797d6b9a91fb065fbbbbc67c61a3c0b67cd90 /dev-python/pplpy
parentdev-python/fpylll: new package, add 0.6.0 (diff)
downloadgentoo-6f5d9fad0e665544f0a10fcf86c9565cbb399485.tar.gz
gentoo-6f5d9fad0e665544f0a10fcf86c9565cbb399485.tar.bz2
gentoo-6f5d9fad0e665544f0a10fcf86c9565cbb399485.zip
dev-python/pplpy: new package, add 0.8.9
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/Manifest1
-rw-r--r--dev-python/pplpy/metadata.xml27
-rw-r--r--dev-python/pplpy/pplpy-0.8.9.ebuild49
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pplpy/Manifest b/dev-python/pplpy/Manifest
new file mode 100644
index 000000000000..b51b6c65f034
--- /dev/null
+++ b/dev-python/pplpy/Manifest
@@ -0,0 +1 @@
+DIST pplpy-0.8.9.tar.gz 66017 BLAKE2B 90da3b4c3e992d0ca969925d8142b114fbbfd5214a768f2e56825d8689e2c4aa2e68a3fa45da9df68168a28413153eb189df277157823e88503668be5c26505c SHA512 618a0a1d603e2859313ad4f71b3cc40156a06371c6b8971fdab8275f6676fc19510e3927828c641819399b5ea6646e954738309fbf8c10fba5733c7410ed75fc
diff --git a/dev-python/pplpy/metadata.xml b/dev-python/pplpy/metadata.xml
new file mode 100644
index 000000000000..18bf8b9ca3a9
--- /dev/null
+++ b/dev-python/pplpy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pplpy</remote-id>
+ <remote-id type="github">sagemath/pplpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pplpy/pplpy-0.8.9.ebuild b/dev-python/pplpy/pplpy-0.8.9.ebuild
new file mode 100644
index 000000000000..91a965367055
--- /dev/null
+++ b/dev-python/pplpy/pplpy-0.8.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the Parma Polyhedra Library (PPL)"
+HOMEPAGE="https://pypi.org/project/pplpy/
+ https://github.com/sagemath/pplpy"
+
+# The file headers under ppl/ contain the "or later" bit
+LICENSE="GPL-3+"
+
+# API/ABI changes in point releases
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-libs/ppl
+ dev-python/cysignals[${PYTHON_USEDEP}]
+ dev-python/gmpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ # Parallel build breaks the test suite somehow. This should be
+ # reported upstream but first someone will need to figure out
+ # how to reproduce it outside of Gentoo.
+ distutils-r1_python_compile -j 1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all(){
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test(){
+ "${EPYTHON}" setup.py test || die
+}